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Introduction to Ivory Service Architect 

Ivory Service Architect easily extends access to the mainframe through Web services—with no 

code written, generated, or changed, and with no additional MIPS usage. Mainframe integration 

is quick and easy, regardless of platform, programming language, or data format. With Ivory 

Service Architect, mainframe developers can seamlessly integrate new technologies like mobile, 

Web-based portals, business process management and packaged applications. 

The main components of Ivory Service Architect are: 

 Ivory Studio 

 Ivory Server 

Ivory Service Architect makes Web service development and deployment simple. Developers 

use Ivory Studio, an intuitive drag-and-drop tool, to assemble Web services from mainframe 

applications and data without additional coding. Developers define Web service inputs and 

outputs, and then graphically model the multi-step process to implement the service. 

Ivory® Server publishes information from Ivory Studio, accessing applications and data directly 

in each native environment. Ivory Server can be deployed on or off the mainframe. 
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What is Ivory Studio? 
Ivory Studio is a PC-based IDE that provides common ground for mainframe programmers and 

PC developers to use existing business logic to drive new SOAP/REST services. The drag-and-

drop graphical modeler provides "end-to-end" representations of business logic and data flow. 

The graphical models present complex business processing in an easy-to-follow diagram. 

Ivory Studio provides the means to design a SOAP/REST Web service for existing business logic 

and deploy the process without having to write any program code. Ivory Studio also provides 

Callable services, which enable your CICS, IMS and batch applications to consume Web 

services. 

The Ivory Studio modeler provides an easy-to-use method for diagramming CICS TS 

transactions and application program flow. You define the inputs and expected outputs, and 

then design the Web service using the component icons. The end result is a graphical design of 

the application from the Web service inputs to the final Web service response. 

Ivory uses an open XML format to ensure that it is compatible with other systems. 

Ivory Studio includes an FTP client to pull copybooks and BMS macros from mainframe file 

systems. They can then be imported by Ivory Studio and converted into an XML format. 

Effective with version 4, Ivory Studio also offers a graphical user interface and IDE for creating 

and maintaining maps. Ivory BMS Studio takes advantage of SOA technologies, using built-in 

Web services to extend the capabilities of BMS/TS. Ivory BMS/TS (release 8.4 and later) 

provides SOA-based Web services for use with Ivory BMS Studio. Ivory BMS Studio is a 

separately licensed feature of Ivory Service Architect. 
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What is Ivory Server? 
Ivory Server processes information published via Ivory Studio, accessing 3270, CICS, IMS, and 

data directly in each native environment. Ivory Server consists of a high-performance SOAP 

processor, a business service flow processor, and a central repository for WSDL discovery.  

The server receives SOAP / REST (XML and JSON) requests, invokes the business service flow 

previously defined in Ivory Studio to satisfy the request, and formats the response. Ivory 

Server provides this support via HTTP and HTTPS protocols. 

Ivory Server can execute custom code within the same address space—or process—when 

“delegates” are added to Ivory projects. Delegates are user written programs that provide Ivory 

users a method to locally access additional programming logic that's normally not available 

through service processing. 

Ivory Server exploits CICS, IMS, and native data access capabilities, eliminating the need for 

middle-tier servers, and providing the flexibility to fully leverage mainframe processing power 

as appropriate within the SOA. Ivory Server optimizes the storage of data dynamically by only 

saving data as needed to serve the application or send output for the SOAP response. 

For the zSeries environments, the Ivory Server supports zIIP, zAAP, and IFL specialty engines 

to help manage and control the z/OS General Processor use when processing services. 

There are several Ivory Server products, including: 

 Ivory Server for CICS/TS 

 Ivory Server for z/OS 

 Ivory Server (Java) for Windows 

 Ivory Server (Java) for Linux 

 Ivory Server (Java) for zLinux 
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Frequently Asked Questions 

How can I control access to the server? Answer 

How does Ivory use WSDL? Answer 

How do I build a Visual Studio ASP.NET application to access a Web service?  Answer 

How can I improve Ivory Server performance?   Answer 

During a 3270 session, can Ivory perform other processing (such as calling a LINK or IMS 

program or an external Web service) without terminating the 3270 session?  Answer 

How do I upgrade to Ivory from Process Extender (Novation)?  Answer 

What is the transaction flow of an HTTP request sent to Ivory Server?  Answer 

How can I define a different transaction code for each Web service?  Answer 

How can I add a user transaction ID based on a URL?  Answer 

How do I expand the diagram size?  Answer 

How do I move dockable windows?  Answer 

How do I connect to a node that isn't visible on the diagram?  Answer 

Why is some text in Ivory Studio truncated or aligned improperly?  Answer 

How can I verify that the Ivory internal Web services are functioning correctly?  Answer 
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How can I control access to the server? 
Suppose that you only want to allow company employees to access the server. One way to 

restrict access is to allow only IP addresses (or DNS names) used by your company. 

Create an {allow} section in the Ivory:/etc/giiipasp.ini file with entries that define the IP 

address ranges or DNS name forms used by your company. The {DAEMON} section must also 

include an entry specifying "Access_Rules=Allow". 

{Daemon} 

... 

Access_Rules=Allow 

... 

 

{allow} 

*.mycompany.com=allow anyone with a DNS name ending in ".mycompany.com" 

10.1.2.*=allow anyone with an IP address starting with "10.1.2." 

 

Suppose that you want to deny access to a specific user. One option is to deny the IP addresses 

(or DNS names) used by the user. 

Create a {Deny} section in the Ivory:/etc/giiipasp.ini file with entries that define the IP 

address ranges or DNS name forms used by that person. The {DAEMON} section must also 

include an entry specifying "Access_Rules=Deny". 

{Daemon} 

... 

Access_Rules=Deny 

... 

 

{deny} 

1.2.3.4=do not allow requests from IP address 1.2.3.4 

*.undesired.domain=reject requests from undesired domain 

 

Refer to /Ivory_doc/listener/server/gtssecr.htm#server_access_rules for more 

information. 
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What do I need to know about WSDL? 
You do not need to know WSDL in order to use Ivory, but a working knowledge of WSDL basics 

will be helpful. 

Web Services Description Language (WSDL) is an XML format for describing network services. A 

WSDL document defines services as collections of network endpoints (or ports). WSDL is an 

integral part of UDDI, an XML-based worldwide business registry. 

Ivory Web services support SOAP bindings only. Two styles of messaging for operations are 

supported: Document or RPC. Document-oriented messaging implies that messages contain 

XML documents that represent application data. RPC-oriented messaging implies that messages 

contain parameters and return values for remote procedure calls. 

Message parts are also affected by the encoding style, which can be either literal or encoded. 

The most common binding styles are document/literal and RPC/encoded, which are both 

supported by Ivory. For the document/literal binding style, Ivory uses a subset of the binding 

style named document/literal wrapped, which wraps the operation name as the top-level 

element in the message. The document/literal wrapped binding style is WS-I Basic Profile 1.0 

compliant. 

The Encoding Style property on the project Start Node specifies which style will be used for that 

project. 

Refer to <http://www.w3.org/TR/wsdl> for detailed information about WSDL. 

How do Ivory projects use WSDL? 

 Ivory Studio can use existing WSDL documents as a reference to define initial inputs and 

outputs for Ivory Web service or Callable service projects. Those initial inputs and outputs 

can be modified in Ivory Studio. 

 An Ivory project can call external Web services using Web Service Client Point Nodes. The 

node specifies the URI location of the WSDL document for the external Web service that 

will be called. Ivory reads this document to determine the SOAP inputs, outputs, and Web 

service operations that are available in the external Web service. The user chooses which 

operation(s) to call and uses movement nodes to move data to the inputs and from the 

outputs. 

 During the build of a Web Service project, Ivory Studio generates a WSDL document based 

on the Web service operations, SOAP inputs, and SOAP outputs defined in the project 

diagram. This document has the same name as the project file, with the .wsdl file 

extension. You can access the WSDL file from the Explorer window. Clients of the Ivory 

Web service use the details provided by the WSDL document to determine how to 

communicate with the Web service. 

 Ivory supports loosely typed Web services with extendable SOAP data by providing two 

special wildcard data types: Any Group and Any Attribute Group. When you define SOAP 

data with either of these types, Ivory generates a schema definition in the project WSDL 

stating that the data can be any element or any attribute (respectively). In effect, these 

data types indicate that, at runtime, the SOAP data can vary between requests. You must 

provide a type definition for an Any Group or Any Attribute Group in the SOAP data for the 

Web Service Operation Node and Web Service Client Point Node. 



Frequently Asked Questions 

8 Frequently Asked Questions Ivory Service Architect 

WSDL Input to Ivory 
Item Description 

Callable Service 

Operation Node  

The Reference WSDL properties enable you to use an existing WSDL 

document to populate the callable inputs and outputs. 

WSDL Location 

From the Set WSDL Location dialog, select the WSDL you want to use 

for this Callable service operation. The callable inputs and outputs will 

be initially populated from this WSDL, though you can modify those 

values. 

Caution: When you select a WSDL Location, it will overwrite any 

callable inputs or outputs you have previously defined for the node. 

Reference Web Service 

This field is automatically populated when you select a Reference WSDL 

Location. If there is more than one Web service defined in the 

Reference WSDL, select from the drop-down list. 

Reference Web Service Operation 

This field is automatically populated when you select a Reference WSDL 

Location. If there is more than one Web service operation defined in 

the Reference WSDL for the Web service, select from the drop-down 

list. 

Web Service 

Operation Node  

The Reference WSDL properties enable you to use an existing WSDL 

document to populate the SOAP inputs and outputs. 

WSDL Location 

From the Set WSDL Location dialog, select the WSDL you want to use 

for this Web service operation. The Web Service Name, Web Service 

Operation Name, SOAP inputs, and SOAP outputs will be initially 

populated from this WSDL, though you can modify those values. 

Caution: When you select a WSDL Location, it will overwrite any SOAP 

Inputs or SOAP Outputs you have previously defined for the node. 

Reference Web Service 

This field is automatically populated when you select a Reference WSDL 

Location. If there is more than one Web service defined in the 

Reference WSDL, select from the drop-down list. 

Reference Web Service Operation 

This field is automatically populated when you select a Reference WSDL 

Location. If there is more than one Web service operation defined in 

the Reference WSDL for the Web service, select from the drop-down 

list. 

If your project requires <any> support, remember to define the 

appropriate SOAP inputs, SOAP outputs, SOAP header inputs, and 

SOAP header outputs.  
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Item Description 

Web Service Client 

Point Node  

The WSDL Location property specifies the URI (Uniform Resource 

Identifier) of the WSDL document for the external Web service you 

want to call. 

Click to open the Set WSDL Location dialog. This dialog lists the 

WSDL sources supplied with Ivory Studio, as well as any other 

resources you've added through WSDL profiles. 

If your project requires <any> support, remember to define the 

appropriate Web Service Client SOAP inputs, SOAP outputs, SOAP 

header inputs, and SOAP header outputs.  

WSDL Output from Ivory 
Item Description 

Start Node  For a Web service project, the WSDL Location property specifies the 

URI (Uniform Resource Identifier) for the WSDL document that is 

generated during the project build. 
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How do I build a Visual Studio ASP.NET application to access 
a Web service? 
Here's an example that imports WSDL to create a simple ASP.NET application to access the 

supplied AcctMain sample. (You'll need to build and deploy the AcctMain sample project.) 

1. In Visual Studio, create a new ASP.NET Web application: from the main menu, select 

File> New Project. 

2. In the New Project dialog, select Visual C# as the project type, and ASP.NET Web 

Application as the template. Specify the location for the ASP.NET application, and then 

click OK. For this example, the location is: 

<http://localhost/AcctMain> 

3. Select View> Solution Explorer to display the Solution Explorer, if it is not already open. 

4. In the Solution Explorer, right-click the References node and select the Add Web 

Reference option. This will display the Add Web Reference dialog. 

5. In the URL text box of the Add Web Reference dialog, enter  

<http://localhost/soap/samples/acctmain?WSDL> 

6. Click Go to display an HTML page describing the WSDL. 

7. Click Add Reference to add the WSDL reference to project. 

8. Go to the Solution Explorer tab and select the WebForm node called WebForm1.aspx, 

which is created by default. Right-click WebForm1.aspx and select Open. This will open a 

design view MDI tab with a blank form. 

9. Select View> Toolbox to open the ToolBox window. Drag and drop 3 labels, 3 text boxes 

and a button from the toolbox onto the design view and position them. 

10. Select View> Properties to open the Properties window, if it is not already open. 

11. Define the text property for the labels: First Name, Last Name, and Account Number. 

12. Define the text box ID properties: TxtFirstName, TxtLastName, and 

TxtAccountNumber. 

13. Define the text property for the button: Submit. 

14. Double-click the button to view the source code for the form with a template for the button 

click event handler. In the given solution, it is: 

private void Button1_Click(object sender, System.EventArgs e) 

{} 

15. Insert code to call the Web service operation. For example, here is code to call the 

supplied AcctMain sample: 

//get firstName value from Text Field 

string firstName = this.TxtFirstName.Text; 

//get lastName value from TextField 

string lastName = this.TxtLastName.Text; 

//Create an instance of the web service class. 

AcctMain.com.yourdomain.yourhost.AcctMain acctMain = new 

AcctMain.com.yourdomain.yourhost.AcctMain(); 

//Call the operation GetAccountNum. It returns a complex type  

//"AcctInfoType". .Net creates a class for each complex type. 
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//The Account Number is a member of the class. Assign the  

//accountNumber value to display in the AccountNumber  

//text box. 

AcctMain.com.yourdomain.yourhost.AcctInfoType infoType = 

acctMain.GetAccountNum(lastName, firstName); 

//Get AcctInfoType instance and obtain value of member accountNumber.  

this.TxtAccountNumber.Text = infoType.accountNumber; 

16. Run the application using Debug> Start. This will display the Web form on an HTML page 

with the defined text fields for input. Enter values into the name text fields, and click 

Submit to access account number values from the Web service. 
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How can I improve Server performance? 
1. Place the IV$FILE in an LSR pool. (Data CI size is 26K, key CI size is 1536) 

Benefit: This results in reduced physical I/O on the IV$FILE and a reduction of CPU 

consumption at a cost of increased storage usage. 

2. Define the IV$FILE as a CICS maintained table (see below). The IV$FILE must already be 

defined in an LSR pool; see above. 

Benefit: This will improve the I/O processing of the IV$FILE and reduce the response time 

when running in an MRO situation more than using only an LSR pool. 

 

3. Verify that the server DNS settings have been configured properly. Using the Ivory Server 

Administration Manager, go to Server Controls> Ivory Listener> DNS> DNS Settings 

and verify that the DNS Name Suffx and DNS IP Address settings have been updated with 

the correct values for your installation. 

To measure performance, monitor all IVCW transactions and all defined alias transactions. 
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During a 3270 session, can other processing be performed 
without terminating the 3270 session? 
During a 3270 session, can Ivory perform other processing (such as calling a LINK or IMS 

program or an external Web service) without terminating the 3270 session? 

Yes, Ivory provides ways to logically suspend an active 3270 session, do other processing, and 

then resume the 3270 session. You can have an implicit suspend and an explicit suspend. 

Implicit Suspend 

There may be 3270 Point Nodes that are indirect descendants (not immediate children) of the 

3270 Action Node, but they are part of the same 3270 session (they occur before another 3270 

Process Node). If the diagram is arranged in this way and if Ivory Server doesn't find a direct 

child 3270 Point Node that matches the next runtime screen, then Ivory Server will logically 

suspend the 3270 session and execute the path of the first non-3270 Point Node child. When 

Ivory Server encounters the next 3270 Point node in this path, the 3270 session is resumed, 

provided that this 3270 Point Node does match the next runtime screen; otherwise it is a SOAP 

fault. 

Explicit Suspend 

The service may need to use data fields from the last active 3270 screen as inputs to a LINK 

program or external Web service call (Web Service Client). This is not possible using the implicit 

suspend method because the 3270 Point Node for the active screen does not occur in the 

diagram until after the nodes for the other processing. 

In this case, you need to perform an explicit suspend, as follows: 

 Establish an active 3270 session with a 3270 Process Node followed by any number of 

3270 Point Nodes and 3270 Action Nodes. 

 At the point where you want to do other processing, place a 3270 Action Node followed by 

the 3270 Point Node representing the resulting screen. 

 Then insert a second 3270 Action Node with AID Key set to “Suspend”. This explicitly tells 

Ivory Server to logically suspend the 3270 session. 

 Following this 3270 Action Node, insert nodes to perform the other processing (LINK, IMS, 

or Web Service Client). 

 When you want to resume the 3270 session, insert another 3270 Point Node with the 

same map as the 3270 Point Node before the “Suspend” 3270 Action Node. 

Using this method, nodes doing the other processing can use fields from the 3270 Point Node 

preceding the “Suspend” 3270 Action Node as inputs. 
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How Do I Upgrade from Process Extender (Novation)? 
Existing Process Extender (formerly Novation) customers should follow the steps below to 

upgrade to Ivory. 

1. Backup Process Extender (Novation) files. 

Use IDCAMS to backup your current GI$FILE and any other Process Extender (Novation) 

files. 

2. Download installation files. 

Your software provider will direct you to a download location on the GT Software FTP site. 

Download the specified .zip file and unzip it to your hard drive. 

3. Prepare XMIT jobs. 

After you unzip the file, you will see the INSTLIB directory. There you'll find the following 

jobs: CDFIX01.TXT, CDTSK01.TXT, CDTSK02.TXT and CDTSK03.TXT. 

Alter these jobs and use them to pre-allocate, upload, and RECEIVE the XMIT files on your 

mainframe. 

4. Modify the CSD. 

Copy member SAMPLIB(GIICSD) to another name, such as GIIGTI. Then modify GIICTI by 

changing all of the transaction codes from IV* to GI*, using a command such as the 

following: 

C ‘TRANSACTION(IV’ ‘TRANSACTION(GI’ ALL 

Change the CSD group name from Ivory30 to IvoryGI. 

Use the INSTLIB(TASK04) job to add the new CSD to your region. You do not need to run 

all of the CSDs; just install the IvoryGI member that has the Ivory programs and GI* 

transactions defined. 

5. Add Ivory LOADLIBS to CICS startup JCL. 

Place the Ivory LOADLIBS in your CICS startup JCL. Place both libraries in front of your 

existing Process Extender (Novation) libraries. 

6. PLT startup/shutdown. 

If you are using the PLT to startup and shutdown Process Extender (Novation), you will 

continue to do so when using the Ivory code base. Leave GTIPLTSI and GTIPLDSD in your 

PLT table. 

7. Restart the CICS region. 

After you restart the CICS region, verify that the proper groups have been loaded. All GI* 

transactions should now be running Ivory programs. For example: GIAS should be running 

program GIIIPASP. 

8. Apply Ivory passwords. 

Use the GII transaction to apply passwords to the file. Passwords are provided by your 

software supplier. 

9. Backup existing INI files. 

Using the GIC transaction, switch to directory \ETC. 

Check whether you have a directory under \ETC named SAVE. If not, create it. 
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From the \ETC directory, type the command COPY GTI*.INI GT:\ETC\SAVE 

This will backup all of the INI files to the \SAVE directory. 

10. Copy the INI files. 

Using the GIC transaction, copy the existing GTI*.INI files to GII*.INI files. You must copy 

these files one at a time. 

Use DIR GTI*.INI to get a list of the INI files. Then copy each one to its new name; for 

example, COPY GTIIPASP.INI GIIIPASP.INI. 

11. If using CGIs, re-link your programs. 

If you use CGIs, re-link your programs using the HFSAPI from the Ivory LOADLIB. 

12. Recycle region or shutdown GIAS and GIRV. 

Recycle the CICS region (recommended), or use SHUTDOWN commands to stop the server 

and FTP. The SHUTDOWN commands are: GIAS SHUTDOWN and GIRV SHUTDOWN. 

13. Test. 

Begin testing. You will be using the GI$FILE and the GI* transactions just as before. 
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What is the transaction flow of an HTTP request? 
1. A connection from an external agent (application) arrives at the host system. 

2. Based upon the TCP/IP service definition, this triggers transaction IVCW; the port for this 

service is 8080. 

I TCPIPS(Ivory*) 

 STATUS: RESULTS - OVERTYPE TO MODIFY 

  Tcpips(IvoryTCP) Bac( 00010 ) Con(0000) Por(08080) Http Nos 

        Ope Tra(IVCW) Urm( GIIANALZ ) Ipa(0.0.0.0    ) Tim 

3. The Transaction IVCW is defined as follows: 

I TRANS(IVCW) 

STATUS: RESULTS - OVERTYPE TO MODIFY 

 Tra(IVCW) Pri( 001 ) Pro(DFHWBXN ) Tcl(DFHTCL00 ) Ena Sta 

       Prf(DFHCICST) Uda Any Iso        Bac Wai 

4. The application makes a SOAP request using URL with SOAP request packets. 

For example: <http://your_Ivoryserver.com:port/soap/test/test>. 

5. The IVCW task associated with that socket session will read the inbound request. 

6. DFHWBXN then links to GIIANALZ, which is the program specified in the URM parameter of 

the TCPIP Service definition. 

7. GIIANALZ is passed a COMMAREA which it will populate with information which CICS Web 

Services (DFHWBXN) will use to start an alias transaction (to process the request). This 

information includes the alias transaction ID to use, and programs to invoke to process the 

request. 

8. GIIANALZ examines the URL and sets an alias transaction based on the URL method 

defined by the Ivory Administrator. For example, by default, any URL containing "/soap/" 

will set the alias transaction IVWA which is defined as follows: 

I TRANS(IVWA) 

STATUS: RESULTS - OVERTYPE TO MODIFY 

 Tra(IVWA) Pri( 001 ) Pro(DFHWBA ) Tcl( DFHTCL00 ) Ena Sta 

       Prf(DFHCICST) Uda Any Iso        Bac Wai 

If you decide to create your own alias transactions, you should clone (copy) the IVWA 

transaction and make your own transaction. You should not reuse existing transaction IDs. 

9. The alias transaction (IVWA or your defined transaction) processes the application logic. 

a) DFHWBXN performs further processing of the request based on the information 

output in the COMMAREA passed to GIIANALZ. This includes: 

 performing optional code page conversion 

 performing optional transformation (unescapDevaSearching) of HTML entity tags 

 starting the alias transaction (optionally with the user ID specified by GIIANALZ) 

b) The alias transaction (IVWA) has been started. DFHWBA links to the program 

specified in the converter field (this is GIISOAP in the "/soap/" example) for the 

"decode" stage. 

c) In the decode stage, GIISOAP parses the XML, loads the appropriate Ivory project 

and executes the commands contained therein. GIISOAP then returns to DFHWBA. 
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d) DFHWBA links to the service program from the Server method definition. (For 

Ivory SOAP server processing, this field is empty and no link occurs.) 

e) DFHWBA then links to GIISOAP for decode processing. GIISOAP performs 

processing necessary to complete the response and returns to DFHWBA. 

f) CICS Web Services returns the Web Service response to the user agent 

(application). 

g) Further requests from the user agent (application) go into step 3 above. 

The IVCW task remains active as long as the socket session with the client is 

active) This duration can be tuned by configuration of the SOCKETCLOSE parameter 

of the TCPIPService definition. 

h) When the socket session closes, the IVCW task associated with the socket session 

terminates. 
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How can I define a different transaction code for each Web 
service? 
To add a user transaction ID based on a URL, you must modify the Ivorycwi.ini file. You can 

use the Ivory Administration Manager tool to modify the file. 

Modify the IvoryCWI.INI File Using the Ivory Administration Manager Tool 

1. Log on to the Ivory Administration Manager in a browser window using the URL below. 

<http://your.Ivoryserver.com:nnnn> 

2. Select Server Controls. 

3. From the Server Controls panel, select Methods. 

 

Before you continue, you need to understand how Ivory processes a URL. 

A typical URL has the format <http://www.yourcompany.com:port/soap/xyz/abc>. The URL 

identifies a directory structure that describes where the information is located. 
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GT uses portions of the URL as a "method” to describe its properties. For example, in our 

example, /soap/, /xyz/, or /abc can be a method. 

The URL that the client application passes to Ivory server is parsed through the {Methods} 

section of the IvoryCWI.ini file. 

The Server Methods section tells Ivory Server how to process the request: commonly a SOAP 

request, script request, or default HTML page retrieval. If there is not a match in this section, 

by default Ivory will treat the request as an HTML page retrieval. 

For example, let's use the URL 

<HTTP://www.yourcompany.com:port/soap/samples/acctmain>. 

To examine the details of the SOAP method, select the Expand radio button and then click 

Process. You'll see that the method is processing the IVWA transaction using the GIISOAP 

converter module. The userID entry of * indicates that you want to validate the RACF userid. 

4. On a blank line, type in the URL pattern in the left column, and then identify the user-

defined method in the center column. Select the Add option, and then click Process to 

add the entry. 

Note: The user-defined method name cannot contain blanks or special characters. 

5. Select the Expand option for the new entry, and then click Process. This displays the 

parameters for the user-defined method. 

6. Specify the following parameters: 

o Description 

o Alias_TransID (Must be defined to CICS using CEDA, with parameters identical to the 

IVWA transaction) 

o Converter (GIISOAP) 

7. Click Process. 

If you want security for the new method, continue with step 8; otherwise, skip to step 13. 

8. Select the Security: Basic Authentication option from the Server Controls menu. 

9. On a blank line, type the method (such as /signon/*), and then add a description of the 

entry in the field to the right. 
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10. Select the Add radio button and then click Process. 

11. Click the Utilities tab at the top of the screen. 

12. Select Control Queue and then click Process. This will clear the temporary storage 

queues and activate the new settings. 

13. Click Save and Exit to save your changes and exit the Ivory Server Administration 

Manager. 

Caution: If you do not click Save and Exit, your changes will be lost! 

For more information, refer to Using the Analyzer Initialization File and URL Processing of 

IvoryCWI.INI Methods. 
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How can I add a user transaction ID based on a URL? 
1. Start the Ivory Administration Manager: in a browser window, type the URL 

<http://local_host:port/Ivory.lua>. 

2. Log on to Ivory Server administration. 

3. Select Server Methods. 

4. On the last line, type the URL portion in the first column, and then type the Methods 

section name in the next column. (Do not use blanks or special characters.) Select the 

Add option, and then click Process. 

For example, you might enter the URL */mytest/* and name the method mytestsrv. 

5. Select the Expand option for the newly added URL, and click Process. The selected entry 

is expanded to display method details. 

6. Define the method parameters: 

o Specify the Alias_Tranid; this transaction must be defined to CICS using CEDA and 

clone the IVWA transaction); for example, TST1. 

o Enter the Description. 

o Specify the Converter name (GIISOAP). 

7. Click Process. 

This creates an entry in the Ivory cwi.ini file for the new server method mytestsrv, which is 

associated with the transaction TST1. 
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How do I expand the diagram size? 
The diagram size increases as components are added. You do not need to manually specify the 

diagram size. 

For example, if you want to begin adding components to the right of the existing diagram 

border, add the next component and drag it to the right edge. When you release the mouse 

button, the new node will be positioned to the right of the former edge. 

You can add components in any direction: up, down, left or right. 
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How do I reposition a dockable window (such as Toolbox, 
Explorer, Properties, Output)? 
To move an Ivory dockable window, simply click and drag the title bar of the dockable window 

you want to move. You must place the mouse cursor on the line that forms the border you want 

to dock against. When you release the mouse button, the window will dock in the new position. 

If the window remains in its previous position, you need to try again! Be sure to drag the 

mouse pointer over the border where you want to dock. When you've reached the right 

position, you will see the outline of the new location where the window will be docked, and 

the mouse pointer will change from the Ø symbol. 

For example, if you want to move the Toolbox from the left side to the right side, click and drag 

the "Toolbox" title bar. Drag the mouse to the far right side of the screen. When the mouse 

pointer is over the line at the right edge of the Ivory Studio window, you will see the outline of 

the new window location. 

Below are samples of the right way and the wrong way to reposition a dockable window. Notice 

the location of the mouse pointer and the outline of the dockable window. Release the mouse 

button and it will dock to this location. 

Right way: 

 

 

Wrong way: 
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To group multiple dockable windows so that they are tabbed, drag the title bar of one dockable 

window on top of the title bar of another dockable window and release the mouse button. 

To remove a dockable window from a tabbed group, click and drag it by the tab rather than the 

title bar. 

You can select Window> Default Window Layout to easily return to the default layout. 
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How do I connect to a node that isn't visible on the diagram? 
One quick solution is to change the size of the entire diagram so that you can see both nodes at 

once. To do this, go to View> Zoom, and select a different zoom value. For example, if you're 

working at 100% resolution, changing to 50% will double the viewable area of the diagram. 

Then connect the nodes as usual. You can return to the original resolution at any time. 

This method is quick, but some users may have trouble reading the smaller component IDs 

or maneuvering the cursor to the smaller connection points. 

Another way is to scroll the diagram view to locate the second node. 

1. Click on the connection point of one node. (The arrow cursor changes to a hand.) Do not 

release the mouse button. 

2. Move the cursor near the edge of the diagram area and the diagram will start to scroll in 

that direction. (The cursor must be near the edge to start the auto scrolling process.) You 

can scroll up, down, left, or right. Remember that you must hold down the mouse button 

while you scroll. 

3. When you've scrolled to the location of the second node, position the cursor on the target 

connection point. Release the mouse button to complete the connection. 

If you drag the hand outside the diagram screen area then scrolling with stop. When you 

reach the current boundary of the diagram area, scrolling will stop. 

A third option is to create (or move) the second node near the first node and make the 

connection, and then reposition the second node. You'll need to scroll the diagram as explained 

above. 
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Why is some text in Studio truncated or aligned improperly? 
Ivory Studio supports both Normal size (96 DPI) or Large size (120 DPI) display; it does not 

currently support the Custom DPI setting in Windows. Select either Normal or Large size, and 

Ivory Studio should display correctly. 

From the Windows Start menu, select Settings> Control Panel> Display> Appearance, and 

set DPI Setting to Normal or Large. 
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How can I verify that the internal Web services are functioning 
correctly? 
All Ivory internal Web services include a getVersionInfo operation. 

The following data is returned when you call the getVersionInfo Web service operation.  

Item Description 

serviceName Returns the name of the Web service 

serviceCreationDate Returns the date the service was created  

serviceReleaseNumber   Returns the service release number 

currentDateTime Returns the current date and time 

These SOAP outputs are child nodes of the getVersionOut complex type. You can retrieve this 

information when calling the getVersionInfo Web service operation with no SOAP inputs. 
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Getting Technical Support 

Product Documentation 

The online help system is the first place to look when you need information about the product. 

GT Software Website 

From the Support section of the GT website you can: 

 search the Support Portal for knowledge base articles and software downloads 

 submit an Enhancement Request 

Technical Support Staff 

If you cannot resolve the problem using the product documentation or online knowledge base, 

the GT Technical Support staff is available for telephone consultation Monday through Friday 

between the hours of 8:30 AM and 5:15 PM Eastern time. After business hours, you can leave a 

message. Your call will be returned the next business day. Before you call: 

 Try to re-create the problem 

 Have the following information available: 

 Product release number 

 Operating system type and version 

 The text of the system message (if any) 

 Complete description of the problem 

Important: In order to resolve a problem it is important to tell the Technical Support 

representative exactly what was being done when the problem occurred—details are important. 

It may be helpful to make notes about what happened before you call. 

Contacting GT Software 

Visit the GT Software website at http://www.gtsoftware.com 

Send Internet e-mail to sales@gtsoftware.com or support@gtsoftware.com 

To send a facsimile (fax), dial 404-253-1314. 

Call GT Software at 404-253-1300 or toll free: 800-756-43GT (4348). Customers outside 

of the U.S. can contact their authorized GT agent for technical support. If the agent is 

unavailable, contact GT Software directly. 

Documentation version: 291118 

http://help.gtsoftware.com/
http://www.gtsoftware.com/
mailto:sales@gtsoftware.com
mailto:support@gtsoftware.com
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