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Introduction to Ivory Service Architect 

Ivory Service Architect easily extends access to the mainframe through Web services—with no 

code written, generated, or changed, and with no additional MIPS usage. Mainframe integration 

is quick and easy, regardless of platform, programming language, or data format. With Ivory 

Service Architect, mainframe developers can seamlessly integrate new technologies like mobile, 

Web-based portals, business process management and packaged applications. 

The main components of Ivory Service Architect are: 

 Ivory Studio 

 Ivory Server 

Ivory Service Architect makes Web service development and deployment simple. Developers 

use Ivory Studio, an intuitive drag-and-drop tool, to assemble Web services from mainframe 

applications and data without additional coding. Developers define Web service inputs and 

outputs, and then graphically model the multi-step process to implement the service. 

Ivory® Server publishes information from Ivory Studio, accessing applications and data directly 

in each native environment. Ivory Server can be deployed on or off the mainframe. 
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What is Ivory Studio? 
Ivory Studio is a PC-based IDE that provides common ground for mainframe programmers and 

PC developers to use existing business logic to drive new SOAP/REST services. The drag-and-

drop graphical modeler provides "end-to-end" representations of business logic and data flow. 

The graphical models present complex business processing in an easy-to-follow diagram. 

Ivory Studio provides the means to design a SOAP/REST Web service for existing business logic 

and deploy the process without having to write any program code. Ivory Studio also provides 

Callable services, which enable your CICS, IMS and batch applications to consume Web 

services. 

The Ivory Studio modeler provides an easy-to-use method for diagramming CICS TS 

transactions and application program flow. You define the inputs and expected outputs, and 

then design the Web service using the component icons. The end result is a graphical design of 

the application from the Web service inputs to the final Web service response. 

Ivory uses an open XML format to ensure that it is compatible with other systems. 

Ivory Studio includes an FTP client to pull copybooks and BMS macros from mainframe file 

systems. They can then be imported by Ivory Studio and converted into an XML format. 

Effective with version 4, Ivory Studio also offers a graphical user interface and IDE for creating 

and maintaining maps. Ivory BMS Studio takes advantage of SOA technologies, using built-in 

Web services to extend the capabilities of BMS/TS. Ivory BMS/TS (release 8.4 and later) 

provides SOA-based Web services for use with Ivory BMS Studio. Ivory BMS Studio is a 

separately licensed feature of Ivory Service Architect. 



Introduction to Ivory Service Architect 

Getting Started Ivory Service Architect 3 

What is Ivory Server? 
Ivory Server processes information published via Ivory Studio, accessing 3270, CICS, IMS, and 

data directly in each native environment. Ivory Server consists of a high-performance SOAP 

processor, a business service flow processor, and a central repository for WSDL discovery.  

The server receives SOAP / REST (XML and JSON) requests, invokes the business service flow 

previously defined in Ivory Studio to satisfy the request, and formats the response. Ivory 

Server provides this support via HTTP and HTTPS protocols. 

Ivory Server can execute custom code within the same address space—or process—when 

“delegates” are added to Ivory projects. Delegates are user written programs that provide Ivory 

users a method to locally access additional programming logic that's normally not available 

through service processing. 

Ivory Server exploits CICS, IMS, and native data access capabilities, eliminating the need for 

middle-tier servers, and providing the flexibility to fully leverage mainframe processing power 

as appropriate within the SOA. Ivory Server optimizes the storage of data dynamically by only 

saving data as needed to serve the application or send output for the SOAP response. 

For the zSeries environments, the Ivory Server supports zIIP, zAAP, and IFL specialty engines 

to help manage and control the z/OS General Processor use when processing services. 

There are several Ivory Server products, including: 

 Ivory Server for CICS/TS 

 Ivory Server for z/OS 

 Ivory Server (Java) for Windows 

 Ivory Server (Java) for Linux 

 Ivory Server (Java) for zLinux 
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Ivory Studio Quick Start Guide 

This Quick Start Guide introduces you to Ivory Service Architect, and walks you through the 

process of creating Ivory projects. 

Navigating Studio Provides a brief introduction to Ivory Studio. 

Diagram Toolbox Describes the diagram components available in the 

toolbox. 

Sample Project: AcctMain This example shows how to create an Ivory Web service 

using a CICS COBOL program that provides direct access 

to the VSAM file created by the IVYS 3270 transaction. 

This project is based on the supplied AcctMain sample. 

Sample Project: AcctMain3270 This sample Web service performs the same functions as 

the AcctMain sample, except that it uses a CICS 

COMMAREA interface rather than the BMS map. 

This project is based on the supplied AcctMain3270 

sample. 

Note: Complete the ACCTMAIN sample project before you 

start the ACCTMAIN3270 sample project. 

Sample Project: AcctMainEWS This sample project will process a 3270 BMS application 

and call an external Web service. 

This project is based on the supplied AcctMainEWS 

sample. 

Note: Complete the AcctMain and AcctMain3270 tutorial 

projects before you start the AcctMainEWS project. 

 

This guide references sample projects supplied with Ivory. The project files are located in the 

Samples folder. 
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Navigating Studio 
The basics of Ivory Studio navigation are covered here. More detailed information is available in 

the Ivory Studio User’s Guide. 

Project resources are displayed in tabbed MDI document windows; these resources include: 

 Project diagram (see screen shot below) 

 Imported BMS maps as a 3270 screen, BMS source, or imported XML format 

 Imported COBOL copybooks as copybook source or imported XML format 

 Generated WSDL in an XML viewer or Web browser 

 Generated HTML view of the WSDL in a Web browser 

 Ivory Help in a Web browser 

Project tools display in dockable windows; these include (see screen shot below for location of 

tabs):  

 Explorer 

 Toolbox 

 Properties 

 Output 

The yellow sticky notes are an optional way to document information on the diagram without 

altering the operation of the project. 



Ivory Studio Quick Start Guide 

Getting Started Ivory Service Architect 7 

 

Diagram Window 

The diagram window is used to visually represent the data flow for the new Web service. 

The diagram is presented in a tabbed MDI document window. The Ivory Studio toolbox contains 

the components you'll need to create the diagram. The Properties window enables you to define 

values for each component. 

Add a component to the diagram by clicking and dragging from the toolbox onto the diagram. 

The component is positioned at the location where the mouse button is released. When you 

select (click) or add a component on the diagram window, its properties are displayed in the 

Properties window. On the diagram, a colored outline identifies the currently selected node. 

To connect components, click a connection point on one component and drag to a connection 

point on the component to be connected. If you've specified a valid connection, the connection 

will be drawn between the components. If the connection isn't valid, an error message will 

display. An even easier way to connect two nodes: select the first node, and then press and 

hold Shift as you click the second node. Or you can press and hold Shift as you drag a node 

onto the diagram to connect the new node to the previously selected node. 
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You can reposition a component by dragging it to new location, and the connections will remain. 

You can reposition the connector lines by clicking them and using the handles to move the 

lines. 

Explorer Window 

The Explorer is a dockable tool window that displays the contents of the project folder. 

When you create a project, you specify a folder where the project will reside. This folder may 

contain files that are not included in the Ivory project. Files that are included in the project 

appear in bold type, and files that are not included appear in normal type. 

Included Files 

When you "include" a file in a project, you make the file available to associate with a point node 

in the diagram. Being included in the project does not necessarily mean that the file is (or will 

be) used by the project. When you view the project tree, files that are included in the project 

appear in bold type; files that aren't included in the project appear in normal type. 

Included files are used to define project information that is external to Ivory, such as BMS 

mapsets and COBOL copybooks. When you import a mapset or copybook, it is automatically 

included in the currently open project. You must manually include IVB and IVC files that have 

been copied into the project folder. 

To include a file, right-click the file name in the project tree, and then select Include in Project. 

To remove the file from the project, right-click the file name and select Remove from Project; 

the file remains in the folder but it is no longer associated with the project. 

The import process converts a BMS mapset or COBOL copybook file into an XML file so that 

Ivory can work with it in an industry standard format. 

Toolbox Window 

The components found on the Toolbox window are used to construct the Web service diagram 

(model). Using your mouse, you can click on a component in the Toolbox window and drag it to 

the Diagram window to create diagram nodes and define the Web service. 

Toolbox Components 

The Ivory Studio toolbox components are listed in the following table. You'll use these 

components to construct the Web service diagram (model). 

Select a link to view detailed information (in the Ivory Studio User's Guide) about a component. 

Component Description 

3270 Action Node Defines the AID operation that is required to continue 

(move to the next screen). 

3270 Point Node Identifies the BMS mapset and map name available to 

lower level nodes. 
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Component Description 

3270 Process Node Defines the data and operations required for a 3270 

Bridge process. Ivory Server will process the data 

collected by this node to invoke the 3270 transaction and 

start the data collection or processing actions that follow. 

Callable Service Operation Node Identifies inputs, outputs and work variables for the 

Callable service. 

Case Node Used in conjunction with the Switch Node, enables you to 

take different paths in the diagram based on the value of 

a field. 

Connector Node Provides the means to return to the main flow path after 

branching into multiple paths. The connector eliminates 

the need for complex or redundant tree structures. 

Decision Node Enables you to make comparisons between data values 

from point nodes, service inputs, work variables, or static 

text. 

Execute IMS Node Defines the point in the diagram where the IMS OTMA 

connection is made to the IMS transaction defined in 

the parent IMS Point node. 

Execute LINK Node Performs the LINK to the program defined in the previous 

LINK Point node, using the data that has been passed in 

the COMMAREA with one or more Move to COMMAREA 

nodes. 

Execute Web Service Client Node Calls the Web service operation defined in the Web 

Service Client Point node. Following this node, you can 

use the service outputs of the Web Service Client Point 

node as data sources for any subsequent movements or 

decisions. 

Function Node Provides the ability to perform date/time conversion, 

arithmetic operations, and string operations on values 

from any of the available sources. 

IMS Point Node Identifies the name of an IMS transaction that will be 

executed using IMS OTMA functions. This node also 

defines input and output copybooks that give the format 

of the IMS data area before and after the IMS transaction 

is invoked. 

LINK Point Node Defines the CICS application program, as well as the input 

and output copybooks for the current operation. 

Loop Node Defines a point in the Web service operation where a loop 

must occur to collect all the required information. 

Move to 3270 Node Defines the movement of data to the nearest parent 3270 

Point node (BMS map) from valid data sources, including 

3270 field, copybook field, service input, work variable, or 

static text. 
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Component Description 

Move to IMS Node Provides the means to move data to the input copybook of 

the nearest parent IMS Point node. 

Move to LINK Node Defines the movement of data to the input copybook in 

the nearest parent LINK Point node from valid data 

sources, including 3270 field, copybook field, service 

input, work variable, or static text. 

Move to Output Node Defines the movement of data to a service output 

(defined in the parent Web Service Operation node) from 

valid data sources, including the nearest parent point 

node, work variable, or static text. 

Move to Web Service Client Node Defines the movement of data (defined in the parent Web 

Service Operation node) to the service inputs of the Web 

Service Client Point node. 

Move to Work Variable Node Provides the ability to assign values to work variables that 

have been defined in the parent Web Service Operation 

node. This enables you to store information for later use 

in a Decision node or other movement node. 

Operation End Node Signals the end of the Web service operation. 

Start Node Marks the beginning of the diagram and identifies the URI 

of the Web service operation.  

Sticky Note Enables you to add comments to the diagram to make it 

more understandable; it does not perform any processing 

or data collection. 

Switch Node Used in conjunction with multiple Case Node, enables you 

to take different paths in the diagram based on the value 

of a field.  

Web Service Client Point Node Enables you to browse the Web for a WSDL document, 

which defines the available services and operations as 

well as the service inputs and outputs for each operation. 

After you select a WSDL, you select the Web service and 

Web service operation you want to call. 

Web Service Operation Node Defines a single operation within the Web service. There 

can be one or more Web service operations connected to 

the Start node in each Ivory project. This node also 

defines the service inputs, service outputs, and work 

variables for this operation. 

Properties Window 

Once you drag-and-drop a component from the toolbox onto the diagram, a new diagram node 

is created. Each node that is part of the project has properties associated with it. When you 

select (click) a diagram node, the properties window for the node becomes active. 
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Node Properties 

Each node must have a unique Node ID. By default, the Node ID is the node type followed by 

an incremental number. For example, if you place two Decision nodes on the diagram, the Node 

IDs will default to Decision 1 and Decision 2. 

Ivory Studio components are defined with base properties, and may also include advanced 

properties. The Base properties require your attention; they are key to the node's operation. 

The Advanced properties frequently contain default values that you may not have to change. 

Other advanced properties are optional. Click  and  to collapse and expand the property 

groups. 

Node properties defined with non-default values display in the Properties window in a bold font; 

default values display in a normal font. 

If (Collection) appears in the right-hand column, you must open a separate window to define 

the component property. You can access the separate window in two ways:  

 Click the property name in the left column to reveal an ellipsis button  in the right-hand 

column. Click  to open the window to define the property. 

 Click (Collection) in the right-hand column to open the window to define the property. 

The tutorial procedures usually instruct you to click the property name to reveal the ellipsis 

button, but you can use the shortcut and simply click (Collection) to open the next window. 

Output Window 

The Output Window shows the Build Process Summary. The summary provides a brief 

description of the Web service operation(s) in the project, including the location of the WSDL 

document(s). The build summary is not saved; if you need to view the build summary again, 

you can re-run the build process. 

Keyboard Navigation 

Though the documentation often refers to mouse clicks, many navigation operations can be 

performed using the keyboard: 

 Use the arrow keys to select nodes in the diagram 

 Navigate the property grid with the up/down arrow keys to select different properties 

 Press Enter to activate a property's editor or drop-down list 

 Press Tab to switch between the property grid and the diagram 

 Use keyboard shortcut/mnemonic keys for buttons 

 Press Tab to move between panels in pop-up dialogs 

 



Ivory Studio Quick Start Guide 

12 Getting Started Ivory Service Architect 

Sample Project: AcctMain 
This example shows how to create an Ivory Web service using a CICS COBOL program that 

provides direct access to the VSAM file created by the IVYS 3270 transaction. The Web service 

will process name input and return the first entry found with that name to provide the account 

number. 

The basic process of creating a new Web service follows these steps: 

1. Create the project file. 

2. Import BMS mapsets and COBOL copybooks. 

3. Model (diagram) the new Web service and define the component properties. 

4. Build the Web service, and generate the server instructions and WSDL document. 

5. Deploy the project to Ivory Server. 

6. Test the new Web service operation(s). 
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A diagram of the completed project is shown below. 

 

Now let's see how it's done. Begin by creating the Ivory project file. 

  



Ivory Studio Quick Start Guide 

14 Getting Started Ivory Service Architect 

AcctMain Task 1: Create the Project File 

To begin, you will identify a location for the project files and specify a project name. 

A sample AcctMain project is supplied with Ivory. Using the names specified below, you can 

create your own project without modifying the supplied files. 

1. Start Ivory Studio. (Ivory Studio is located in the GT_Software program group.) 

2. From the studio toolbar, select File> New Project> New Web Service Project> SOAP 

to open the New Ivory Project window. 

3. Navigate to the location where you want to store the project files and create a folder 

named Product Tutorial, and then create a subfolder named qs_acctmain. 

4. Open the new subfolder and in the File name field, type my_acctmain for the new project. 

Note: Ivory automatically appends “.ivp" to the file name. 

5. Click Open and a blank Ivory project is created. 

The next step is to import the BMS Mapsets and COBOL Copybooks. 

AcctMain Task 2: Import the BMS Mapsets and COBOL Copybooks 

In this task you will import the resources you need for the project: BMS mapsets, COBOL 

copybooks, or both. For this project, you'll need to import a COBOL copybook, which is provided 

with the Ivory installation. 

Before we begin, set the following two optional View preferences. 

 Select View> Theme> Light. 

 Select View> Grid Lines> Standard. 

1. From the Ivory menu bar, select File> Import Language Source> Select File. 

2. Using the Select Copybook File(s) window, navigate to the location where the COBOL 

copybook resides; in this case, it is the …\Ivory_Studio\version 

x.x\Samples\Ivory_Projects\CICS\AcctMain folder. 

Note: You can import a copybook or mapset from any networked location. If the copybook 

or mapset is not on a networked drive, you must use FTP to transfer it to your PC. You can 

use the built-in Ivory FTP client or a third-party FTP client. 

3. Select the copybook named GIISMCC.CPY and click Open. 

The selected copybook is displayed in the Import Language Source window. 

4. Select the top-level item of the copybook if it is not already selected, and then click 

Import. 

The import operation copies the selected copybook into the project folder and includes it in 

the project. You will receive a confirmation that the copybook was imported successfully. 

Click OK to dismiss this message. 

5. Click OK to close the Import Language Source window. 

Note: The copybook appears in the Project Explorer under its original name with an .ivc 

file extension. Select the Explorer tab to see the imported file as shown below. 
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The next step is to model the Web service operation and define the component properties. 

AcctMain Task 3: Model the Web Service Operation 

Now that you have defined the project and imported the copybook, you are ready to begin 

modeling the new Web service. Modeling the Web service consists of placing diagram 

components and defining their properties. 

You can define node properties when you place the nodes on the diagram, or you can edit 

the node properties later. In this example, we will define node properties as we place the 

nodes on the diagram. 

Accept the default value for any node properties that are not specifically defined in these 

instructions. 

You should have Ivory Studio running and the newly created my_acctmain project open. The 

Explorer, Toolbox, and Properties windows should be open. Use the View menu if necessary 

to open the windows. 

 

1. Click the Toolbox tab to display the component nodes. 

2. Click the LINK group to display just the nodes commonly used in a LINK-type project. 
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You will drag-and-drop nodes onto the diagram window to define the Web service. 

The All group displays the Ivory nodes from all groups for various project types. You can use 

the All group for this project if you prefer. 

Begin by adding a Start node. 

AcctMain Task 3A: Add a Start Node 

All Ivory diagrams begin with a single Start node. The Start node identifies the Web service 

name and is the anchor point for the Web service operations. (Learn more about Ivory Start 

nodes) 

1. Drag a Start node from the Toolbox tab onto the Diagram window. 

2. Select the Properties tab. 
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3. Define the following Start node properties by clicking in the edit field to the right of the 

property label: 

Property Value Comments 

Node ID Last Name to 

Account Number 
Enter a unique name that identifies the Web 

service; this name will be used in the trace file. 

Web Service 

Name 

AcctMain Enter a name for the Web service; this can be 

the same as the project name. 

URI (see comments) Enter the DNS name or IP address and port 

where Ivory Server is running; contact your 

Ivory administrator for assistance. 

Note: It is recommended that a URI prefix be 

entered in the FTP Server Profile and be 

prepended during deploy. In this case, the Use 

URI Prefix During Deploy field (an Advanced 

property) needs to be set to True in the 

Advanced Properties. 

WSDL Location (see comments) By default, this is the URI location, followed by 

"?WSDL". Change it only if you are using a 

different location for WSDL discovery; contact 

your Ivory administrator for assistance. 



Ivory Studio Quick Start Guide 

18 Getting Started Ivory Service Architect 

Property Value Comments 

Encoding Style rpc/encoded Select the format of the service request and the 

service response. 

Web Service 

Description 

Sample Account 

Number Lookup 

by Name 

Enter a description to appear in the WSDL as 

documentation for the Web service. 

After all properties are defined, save your changes and go to Task 3B. 

AcctMain Task 3B: Add a Web Service Operation node 

The Web Service Operation node defines the operation or function for this path in the model. All 

of the input and output for the WSDL are defined in this node. (Learn more about Ivory Web 

Service Operation nodes) 

1. Select the Toolbox tab and drag a Web Service Operation node onto the Diagram 

window below the Start node. 

Ivory Studio automatically draws a connecting line between the Web Service Operation 

node and the Start node. 

2. Select the Properties tab. 

Properties that require input into a separate dialog box display the word Collection to the 

right of the property name. When you select one of these property labels, an ellipsis 

button  displays. You can click the word Collection or click the ellipsis button to display 

the dialog box where you will define the data collection. 

3. Define the following Web Service Operation node properties: 

Property Value Comments 

Node ID GetAccountNum Enter a unique name that identifies the Web 

service operation; this name will be used in the 

trace file. 

Web Service 

Operation 

GetAccountNum Enter a name that Web service clients will use to 

call this operation. 

Message Flow Request 

Response 
Select whether the messages for this service 

operation are bidirectional (Request Response) 

or request only (One Way). 

Service Inputs (see comments) Define these values in the data collection dialog 

box*. 

Service Outputs (see comments) Define these values in the data collection dialog 

box*. 

Work Variables (not used in this 

sample project) 

Work variables are used to store information. 

BLOBs (not used in this 

sample project) 

BLOBs are used to define binary large objects 

for the Web service operation or Callable service 

operation. 

Description Get the account 

number 
Enter a description to appear in the WSDL as 

documentation for the Web service operation. 
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Property Value Comments 

SOAP Header 

Inputs 

(not used in this 

sample project) 

SOAP Header Inputs define input parameters for 

this Web Service operation only. 

SOAP Header 

Outputs 

(not used in this 

sample project) 

SOAP Header Outputs define output parameters 

for this Web Service operation only. 

Notes 

 You can reposition nodes by clicking and dragging them to a new location. Existing 

connections to other nodes remain intact. 

 You can delete a connection by clicking the connector line and pressing Delete. 

 You can place Sticky Notes on the diagram to store comments. Drag a Sticky Note onto 

the diagram from the Toolbox tab, and then double-click in the note box on the diagram to 

enter text. The note text does not wrap so press Enter to start a new line as needed. 

After all properties are defined, save your changes and go to Task 3C. 

*AcctMain data collection: Service Inputs (Web Service Operation Node) 

The following instructions step you through the process of defining service inputs for the 

Web Service Operation node of the my_acctmain.ivp sample. 

Properties that require input into a separate dialog box display the word Collection to the 

right of the property name. When you select one of these properties, an ellipsis  button 

displays. Click the word Collection or click  to display the dialog box where you will 

define the data collection. 

a) Click the Service Inputs label to reveal the ellipsis  button. 

 

b) Click  to display the Create Service Inputs dialog box. 
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c) Click Add to display an input field. 
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d) Type lastName in the edit box to identify the service input. 

You do not need to change the default properties (in the right-hand pane). 

e) Click Add again to define another service input, and type firstName in the edit 

box that displays. 

You can accept the default properties. 

f) Click OK to save the service inputs and exit the Create Service Inputs dialog box. 

*AcctMain data collection: Service Outputs (Web Service Operation node) 

The following instructions step you through the process of defining service outputs for the 

Web Service Operation node of the my_acctmain.ivp sample. 

The process to define the service outputs is the same as for defining the service inputs. 

a) Click the Service Outputs label to reveal the ellipsis  button. 

 

b) Click  to open the Create Service Outputs dialog box. 

c) Click Add to display an input field. 

d) Type acctInfo in the edit box to identify the service output, and press ENTER. 

e) In the Properties pane, change the Data Type to Complex Type (select from the 

drop-down list). 

You do not need to change the other default properties. 

Note: In this case, the output is a complex data object named acctInfo, which 

consists of the child data objects firstName, lastName and accountNumber. You will 

define those objects next. 

f) With acctInfo highlighted in the left pane, click Add again to define another 

service output as a child of the acctInfo object. 

g) Type firstName in the box below acctInfo. 

You can accept the default properties. 

Caution: These entries are case-sensitive. When you name a child data object (part 

of a complex data object), the name must begin with a lowercase letter. The child 

objects are indented below the parent object. 

h) Click Add again to define another service output and type lastName in the box. 

You can accept the default properties. 

i) Click Add again to define another service output and type accountNumber in the 

box. 

You can accept the default properties. 
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j) Click OK to save the service outputs and exit the Create Service Outputs dialog 

box. 

AcctMain Task 3C: Add a Link Point node 

The LINK Point node identifies a CICS application program that will be called during the 

processing of the Web service request. (Learn more about Ivory LINK Point nodes) 

1. Select the Toolbox tab and drag a LINK Point node onto the diagram below the Web 

Service Operation node. 

2. Connect the Web Service Operation node to the LINK Point node. 

There are several ways to make diagram connections. The quickest is to select the 

previous node on the Diagram window (in this case, the Web Service Operation node), and 

then press and hold Shift as you click the node you want to connect to (in this case, the 

LINK Point node). 

3. On the Properties tab, define the following LINK Point node properties: 

Property Value Comments 

Node ID AcctMain1 Enter a unique name that identifies the node; 

this name will be used in the trace file. 

LINK Type COMMAREA Defines the LINK style to use. COMMAREA 

indicates data will be passed in a traditional 

COMMAREA. 
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Property Value Comments 

Input Type Copybook The type of input associated with this point 

node. 

Input 

Copybook 

Name 

giismcc.ivc Select from the drop-down list of included 

COBOL copybooks. This copybook defines the 

COMMAREA layout prior to the Execute LINK 

node (EXEC CICS LINK). 

Input 

Copybook Data 

 Treeview display of the copybook structure for 

Input Copybook Name. 

Output Type Copybook The type of output associated with this point 

node. 

Output 

Copybook 

Name 

giismcc.ivc By default, this will be the same as the Input 

Copybook Name. This copybook defines the 

COMMAREA layout following the Execute LINK 

node (EXEC CICS LINK). 

If you wanted to select a different output 

copybook, you could click on the Output 

Copybook Name field, and select from the drop-

down list of included COBOL copybooks. 

Output 

Copybook Data 

 Treeview display of the copybook structure for 

Output Copybook Name. 

Program GIISM01 Identify the name of the CICS application 

program that will be called. 

Initialize 

COMMAREA 

Low Values Indicates the values used to initialize the 

COMMAREA. 

After all properties are defined, save your changes and go to Task 3D. 

AcctMain Task 3D: Add a Move to Link node 

The Move to LINK node will pass the input data from the service request to this CICS program. 

Normally this would be data sent during the service request for this Web service. (Learn more 

about Ivory Move to LINK nodes) 

1. Select the Toolbox tab and drag a Move to LINK node onto the diagram below the LINK 

Point node. 

2. Connect the LINK Point node to the Move to LINK node. 

Tip: Click the first node then SHIFT+CLICK the second node. 

3. On the Properties tab, define the Move to LINK node properties: 

Property Value Comments 

Node ID Move 

LastName/FirstName 
Enter a unique name that identifies the 

node; this name will be used in in the trace 

file. 
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Property Value Comments 

Nearest 

Parent Point 

Node ID 

AcctMain1 You cannot edit this field. Ivory 

automatically identifies the nearest parent 

point node.  

Data 

Movements 

(see comments) Define these values in the data collection 

dialog box*. 

After all properties are defined, save your changes and go to Task 3E. 

*AcctMain data collection: Data Movements (Move to LINK node) 

The following instructions step you through the process of defining the Move to LINK data 

movements for the my_acctmain.ivp sample. 

a) Click the Data Movements label to reveal the ellipsis  button. 

 

b) Click  to open the Create Data Movements to Input Copybook dialog box. 

c) Click Add. 

Another dialog box opens, containing the fields of the input copybook (defined in 

the LINK Point node). 

d) Select the All Levels radio button at the top of the dialog box to display fields for 

all levels. 
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e) Add the following fields: 

Tip: Click the first field then press and hold CTRL while you click the additional 

fields. 

 CA-CONVERSATION-STATE 

 CA-MODE 

 CA-DETAIL-DATA.CA-LASTNAME 

 CA-DETAIL-DATA.CA-FIRSTNAME 

f) Click OK to close the dialog box and return to the Create Data Movements dialog 

box. 
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g) In the Move To pane on the left, select Root.GIISMCC.CA-CONVERSATION-

STATE. 

h) In the Move From pane on the right, click Data Source Type and then click  

and select Static Text to display a Static Text Value field. Type an S in the Static 

Text Value field. 

Caution: This field is case-sensitive. 

i) Define the remaining copybook fields: 

Root.GIISMCC.CA-MODE 

Data Source Type Static Text 

Static Text Value S 
 

Root.GIISMCC.CA-DETAIL-DATA.CA-LASTNAME 

Data Source Type Service Input 

In the lower right-hand pane, you will see the service 

inputs that were defined for the Web Service 

Operation node. 

Service Input Select the corresponding service input (in this case, 

lastName) from the lower pane. The Service Input 
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field in the upper pane is automatically filled with the 

name you selected. 
 

Root.GIISMCC.CA-DETAIL-DATA.CA-FIRSTNAME 

Data Source Type Service Input 

Service Input Select the corresponding service input (in this case, 

firstName) from the lower pane. The Service Input 

field in the upper pane is automatically filled with the 

name you selected. 
 

j) Now that you have selected and defined the copybook fields, click OK to save the 

data movements and close the Create Data Movements dialog box. 

AcctMain Task 3E: Add an Execute Link Node 

The Execute LINK node marks the location in the model path where the program call or link will 

take place. (Learn more about Ivory Execute LINK nodes) 

1. Select the Toolbox tab and drag an Execute LINK node onto the diagram below the 

Move to LINK node. 

2. Connect the Move to LINK node to the Execute LINK node. 

3. On the Properties tab, define the following Execute LINK node properties: 

Property Value Comments 

Node ID LINK to 

AcctMain 
Enter a unique name that identifies the node; 

this name will be used in in the trace file. 

Tip: If you are aligning the nodes from the top of the diagram screen to the bottom and you 

leave a lot of space between nodes, you may not be able to view the entire diagram at one 

time. You have some options: you can continue to place the nodes in a linear manner, and 

scroll to see other parts of the diagram; you can arrange the nodes in columns; or you can 

use the View> Zoom feature to display the diagram at a different resolution. 

After all properties are defined, save your changes and go to Task 3F. 

AcctMain Task 3F: Add a Move to Output Node 

This Move to Output node moves data values to the service output fields defined in the Web 

Service Operation node. Any data previously collected can be marked as information to include 

in the service response. The service output fields are the method used to return data to the 

requesting application. (Learn more about Ivory Move to Output nodes) 

1. Select the Toolbox tab and drag a Move to Output node onto the diagram below the 

Execute LINK node. 

2. Connect the Execute LINK node to the Move to Output node. 

3. On the Properties tab, define the Move to Output node properties: 
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Property Value Comments 

Node ID Get AccountNum Enter a unique name that identifies the node; this 

name will be used in in the trace file. 

Service Output 

Data 

Movements 

(see comments) Define these values in the data collection dialog 

box*. 

SOAP Header 

Output Data 

Movements 

 A collection of data movements to SOAP header 

output fields. 

After all properties are defined, save your changes and go to Task 3G. 

*AcctMain data collection: Service Output Data Movements (Move to Output node) 

The following instructions step you through the process of defining the Move to Output 

data movements of the my_acctmain.ivp sample. 

a) Click the Service Output Data Movements label to reveal the ellipsis  button. 

b) Click  to open the Create Data Movements to Service Outputs dialog box. 

c) Click Add. 

Another dialog box opens, listing the Service Outputs from the Web Service 

Operation “GetAccountNum” node. 

d) Click  to expand the list and add the following fields: 

 firstName 

 lastName 

 accountNumber 

Tip: Click the first field then press and hold CTRL while you click the additional 

fields. 

You cannot select fields that have child nodes. 

e) Click OK to close the dialog box and return to the Create Data Movements dialog 

box. 
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f) From the Move To pane on the left, select firstName and define the data element: 

firstName 

Data Source Type LINK Copybook Field 

LINK Point Node AcctMain1 (this default value cannot be changed) 

LINK Copybook Field In the Data Source Tree View in the lower pane, 

expand the nodes necessary to select CA-SEARCH-

DATA.FILLER2.CA-SRCH-FIRST. 
 

g) Select lastName from the left-hand pane and define the data element: 

lastName 

Data Source Type LINK Copybook Field 

LINK Point Node AcctMain1 (this default value cannot be changed) 

Copybook Field In the Data Source Tree View in the lower pane, 

expand the nodes necessary to select CA-SEARCH-

DATA.FILLER3.CA-SRCH-LAST. 
 

h) Select accountNumber from the left-hand pane and define the accountNumber 

data element: 

accountNumber 

Data Source Type LINK Copybook Field 

LINK Point Node AcctMain1 (this default value cannot be changed) 

Copybook Field In the Data Source Tree View in the lower pane, 

expand the nodes necessary to select CA-SEARCH-

DATA.FILLER1.CA-SRCH-ACCT. 

i) Click OK to close the Create Data Movements dialog box and save the data 

movement definitions. 
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AcctMain Task 3G: Add an Operation End Node 

The Operation End node signals Ivory Server that there is no additional processing to perform. 

This will fire the service response from the server. (Learn more about Ivory Operation End 

nodes) 

1. Select the Toolbox tab and drag an Operation End node onto the diagram below the 

Move to Output node. 

2. Connect the Move to Output node to the Operation End node. 

3. On the Properties tab, define the following Operation End node properties: 

Property Value Comments 

Node ID Send Result Enter a unique name that identifies the node; 

this name will be used in in the trace file. 

4. The Diagram is complete. Save the changes to the project. 

Your project diagram should resemble the diagram of the AcctMain sample supplied with Ivory 

(in the \Samples folder). 

The next step is to build the Web service and generate the WSDL document. 

AcctMain Task 4: Build Web Service and Generate WSDL Document 

After you've finished modeling the new Web service operation, you're ready to build it and 

generate the WSDL document. 

1. From the Ivory menu, select Tools> Build. 

o The Output window shows the Build Process Summary. Click the Output tab at the 

bottom of the screen to see the summary. If you cannot see the output, click and drag 

the top of the Output window to expand it. 

After a successful build, the Output window displays the message Build Complete. If 

there are errors, you will see the message Build Complete With Errors. 

The summary provides a brief description of the Web service operation(s) in the 

project, including the location of the WSDL document(s). The build summary is not 

saved; if you need to view the build summary again, you can re-run the build process. 

o The WSDL document is generated. 

This WSDL document is saved using the project name and the WSDL file extension. Go 

to the Explorer window and click the Refresh  button to see the WSDL file 

(my_acctmain.wsdl). 

o An HTML file is generated. 

This HTML file describes the contents of the WSDL document, including the Web service 

name and description, Web service operation name and description, the input/output 

parameters, and a description of complex data types. 

This HTML file is saved using the project name with an HTML file extension. Go to the 

Explorer window and click the Refresh  button to see the HTML file 

(my_acctmain.html). If this filename does not appear in the Explorer window, click the 

Show All Files button. 
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Next you will deploy the project. 

AcctMain Task 5: Deploy the Project 

After you successfully build an Ivory project, you can deploy it to Ivory Server. You must 

deploy the project before you can test it. 

To deploy a project you need an FTP profile. You can use an existing profile or create a new 

one. 

AcctMain Task 5A: Create a Profile (if necessary) 

An FTP profile defines a configuration file required to access the Ivory FTP client and transfer 

files between the FTP remote host and the local host. 

Profiles are described in the Ivory User's Guide. For this example, we'll briefly explain the basics 

of creating an FTP profile for deploying an Ivory project to Ivory Server. 

1. Select Tools> Profiles> FTP Profiles> Add Profile to display the Add FTP Server Profile 

dialog box. 

Note: If an FTP profile has already been defined, it will be listed on the FTP Profiles menu 

under the Add Profile and Delete Profile options. 

2. Complete the Add FTP Server Profile fields (contact your Ivory Server Administrator for 

assistance): 

Field Name Description 

Profile Name Identify the name of the profile. This name will appear on menus 

that prompt you to choose an FTP (TN3270) profile. 

Host Name Specify the host name or IP address of the FTP server. 

Port Number Identify the port number that the FTP server is listening to for FTP 

communications. Typically it is port 21. 

User ID Specify the user ID for the FTP server. 

Password Identify the password associated with the specified user ID. The 

password will not display as it is entered. 

Host Type Specify the remote server type. Currently Ivory supports the 

standard host type (Unix) and MVS host type. Because this profile 

will be used to upload a project to Ivory Server, select the Unix 

(Standard) type. 

Passive 

Transfers 

Select True if the FTP server is to generate data socket values. This 

is useful when Ivory Studio is behind a firewall and the FTP server is 

outside the firewall. If both the client and server are part of the 

same network, select False. 

Deploy URI 

Prefix 

Specifies the prefix to concatenate to the Start node URI. If this field 

is empty, the URI will be used as specified in the Start node. 

The deployment URI prefix can be used whenever a project goes 

through a series of stages such as test, integration, and production. 

By defining separate FTP profiles for each stage, the value of the 

URI property within the Start node can remain the same.  
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Field Name Description 

Operating 

System 

Select the operating system for the FTP server. 

Server Provider Choose th vendor of the transfer server and HFS. GT supports FTP 

transfers to a VSAM file based HFS> IBM supports FTP, SFTP, and 

FTPS transfers to the USS HFS. 

Volume  Identify the destination Ivory Server volume for files stored during a 

Deploy To Server operation. Leave this field blank to use the default 

Ivory: volume. 

If your Ivory Server Administrator has chosen to store Ivory project 

information on a different volume, you must specify the volume 

name. The volume name must end with a colon (: ). 

Host Path Specify the host path or directory on the server where you want to 

store and retrieve project files. This path must exist on the server 

before you can use the FTP upload and download functions. 
 

3. Click Test Connection to verify that the profile settings are correct. 

4. Click OK to save the FTP profile settings and close the dialog box. 

AcctMain Task 5B: Deploy Project to Server 

1. From the Ivory menu bar, select File> Deploy Project to Server and choose the FTP 

profile for the Ivory Server where you want to deploy the project, or select Add Profile to 

create a new FTP profile. 

After you select an FTP profile, Ivory selects and uploads the necessary files for the project 

being deployed, including the server instructions, maps, copybooks, and WSDL documents. 

When the process is complete, Ivory displays the messages Upload Complete and Deploy To 

Server Complete. 

If the upload is not successful, the FTP status messages are sent to the output window to 

help you resolve the problem. 

The files are uploaded to the URI location defined in the Start node of the project diagram, into 

a folder named WebServices and a subfolder using the project name. For example, you have a 

project that defines the Start node URI as http: //dev.gtsoftware.com: 8001/soap/apps/accts. 

Ivory deploys the project files to the /WebServices/soap/apps/accts folder. 

By default, Ivory Server treats any URI that begins with "soap" as a Web service rather than an 

HTML request. 

The Ivory FTP Server and the Ivory CICS TCPIPSERVICE must be active to run the Web 

service operation. 

The final step is to test the new Web service operation. 

AcctMain Task 6: Test the Web Service Operation 

After you deploy an Ivory project, you should test it. 

1. From the Ivory menu bar, select Tools> Test to open the Test document window. 

http://dev.gtsoftware.com:8001/soap/apps/accts
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2. Click Request to open the Request dialog box. 

The tree view lists the service inputs for the GetAccountNum request (defined in the Web 

Service Operation node). In this case, the service inputs are lastName and firstName. 

3. Click lastName. 

In the right-hand pane, you'll see information about the data element. 

4. Click in the Value field and type SMITH. 

5. Click firstName, and type STEVE in the Value field. 

6. Click OK. 

The Request dialog box closes and you see the resulting XML code in the Request. 

<?xml version="1.0" encoding="utf-16"?> 

<soap: Envelope xmlns: xsi="http: //www.w3.org/2001/XMLSchema-instance" 

xmlns: xsd="http: //www.w3.org/2001/XMLSchema" xmlns: soapenc="http: 

//schemas.xmlsoap.org/soap/encoding/" xmlns: soap="http: 

//schemas.xmlsoap.org/soap/envelope/"> 

<soap: Body soapenc: encodingStyle="http: 

//schemas.xmlsoap.org/soap/encoding/"> 

<GetAccountNum> 

<LastName>SMITH</LastName> 

<FirstName>STEVE</FirstName> 

</GetAccountNum> 

</soap: Body> 

</soap: Envelope> 

7. Click Test to generate the Response. 

<?xml version="1.0" encoding="utf-8"?> 

<soap: Envelope xmlns: soap="http: //schemas.xmlsoap.org/soap/envelope/" 

xmlns: xsi="http: //www.w3.org/2001/XMLSchema-instance" xmlns: xsd="http: 

//www.w3.org/2001/XMLSchema" soap: encodingStyle="http: 

//schemas.xmlsoap.org/soap/encoding/"> 

<soap: Body> 

<GetAccountNumResponse> 

<AcctInfo> 

<FirstName xsi: type="xsd: string">STEVE</FirstName> 

<LastName xsi: type="xsd: string">SMITH</LastName> 

<AccountNumber xsi: type="xsd: string">10001</AccountNumber> 

</AcctInfo> 

</GetAccountNumResponse> 

</soap: Body> 

</soap: Envelope> 

8. You can click Response to open the Response dialog box. 

Use the tree view to display the individual data elements of the service outputs: firstName, 

lastName, accountNumber. 

You'll see that the service input (lastName Smith, firstName Steve) returns the service 

output (accountNumber) of 10001. 

To verify that the information you're getting is accurate, you can open an emulator window 

(Tools> Emulator), log on to the mainframe, and verify the results. 
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You have completed the AcctMain sample project—Congratulations! The next Sample 

Project is AcctMain3270. 
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Sample Project: AcctMain3270 
This sample Web service performs the same functions as the AcctMain sample, except that it 

uses a CICS COMMAREA interface rather than the BMS map. 

Important: You should complete the AcctMain sample before you attempt this sample. Many 

important concepts that are explained in the AcctMain sample are not repeated here. 

The process of creating a new Web service operation follows these steps: 

1. Create the project. 

2. Import BMS mapsets and COBOL copybooks. 

3. Model (diagram) the new Web service and define the component properties. 

4. Build the Web service, and generate the server instructions and WSDL document. 

5. Deploy the project to Ivory Server. 

6. Test the new Web service operation(s). 
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A diagram of the completed project is shown below. 

 

Begin by creating the project folder. 

  



Ivory Studio Quick Start Guide 

Getting Started Ivory Service Architect 37 

AcctMain3270 Task 1: Create the Project File 

To begin, you'll identify a location for the project files and identify a project name. 

A sample AcctMain3270 project is supplied with Ivory. Using the names specified below, you 

can create your own project without modifying the supplied files. 

1. Start Ivory Studio. (From the PC Start menu, select Programs> GT_Software> Ivory 

Studio x.x> Ivory Studio.) 

2. From the studio toolbar, select File> New Project> New Web Service Project> SOAP 

to open the New Ivory Project window. 

3. Navigate to the Ivory Tutorial folder that you created for the first tutorial project and 

create a subfolder named qs_acctmain3270. 

4. Open the new subfolder and in the File name field, type my_acctmain3270 for the new 

project. 

Note: Ivory will automatically append “.ivp" to the file name. 

5. Click Open and a blank Ivory project is created. 

The next step is to import the BMS mapsets and COBOL copybooks. 

AcctMain3270 Task 2: Import the BMS Mapsets and COBOL Copybooks 

The next step is to import the resources you need for the project: BMS mapsets, COBOL 

copybooks, or both. For this project, you'll need to import a BMS mapset, which is provided 

with the Ivory installation. 

1. From the Ivory Studio menu bar, select File> Import BMS Mapset> Select File. 

2. Navigate to the location where the BMS mapset resides: in this case, it's the 

\Ivory_Studio\version x.x\Samples\Ivory_Projects\CICS\AcctMain3270 folder. 

Note: You can import a mapset or copybook from any networked location. If the mapset or 

copybook is not on a networked drive, you must use FTP to transfer it to your PC. 

3. Select the mapset named GIISMMA.map and click Open. This will copy the mapset into 

the project folder and include it in the project. The mapset appears in the Explorer under 

its original name with an .ivb file extension. 
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The next step is to model the new Web service operation and define the component properties. 

AcctMain3270 Task 3: Model the Web Service Operation 

Now that you've defined the project and imported the mapset, you're ready to begin modeling 

the new Web service operation. Modeling the Web service operation consists of placing diagram 

components and defining the node properties. 

You can define node properties when you place the nodes on the diagram, or you can edit the 

node properties later. 

In this example, we will define node properties as we place the nodes on the diagram. 

Accept the default value for any node properties that are not specifically defined in these 

instructions. 

You should have the Explorer, Toolbox, and Properties windows open. Use the View menu if 

necessary to open these windows. 

1. Select the Toolbox tab to display the component nodes. 

2. Click the 3270 group to display just the nodes commonly used in a 3270-type project. 
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Begin by adding a Start node. 

AcctMain3270 Task 3A: Add a Start Node 

1. Drag a Start node from the Toolbox tab onto the Diagram window. (Learn more about 

Ivory Start nodes) 

 

2. Define the Start node on the Properties tab: 
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Property Value Comments 

Node ID 3270 Account Lookup A unique name that identifies the Web 

service. 

Web Service Name AcctMain3270 The name for the Web service; this can 

be the same as the project name. 

URI (see comments) Specify the DNS name or IP address 

and port where Ivory Server is running; 

contact your Ivory administrator for 

assistance. 

Note: It is recommended that a URI 

prefix be entered in the FTP Server 

Profile and be prepended during deploy. 

In this case, the Use URI Prefix During 

Deploy field needs to be set to True in 

the Advanced Properties. 

WSDL Location (see comments) By default, this is the URI location, 

followed by "?WSDL". Change it only if 

you are using a different location for 

WSDL discovery; contact your Ivory 

administrator for assistance. 

Encoding Style rpc/encoded Determines the format of the service 

request and the service response. 

Web Service 

Description 

Sample to collect 

3270 data credit 

limit information. 

Appears in the WSDL as documentation 

for the Web service. 

Notes 

 You can place Sticky Notes on the diagram to store comments. Drag a Sticky Note onto 

the diagram from the Toolbox tab, and then double-click in the note box on the diagram to 

enter text. The note text does not wrap so press Enter to start a new line as needed. 

 You can reposition nodes by clicking and dragging them to a new location. Existing 

connections to other nodes remain intact. 

 You can delete a connection by clicking the connector line and pressing Delete. 

After all properties are defined, save your changes and go to Task 3B. 

AcctMain3270 Task 3B: Add a Web Service Operation Node 

The Web Service Operation node defines the operation or function for this path in the model 

and defines the service inputs and outputs for the WSDL. (Learn more about Ivory Web Service 

Operation nodes) 

1. Drag a Web Service Operation node from the Toolbox tab onto the Diagram window. 

Ivory automatically connects it to the Start node. 

2. Define the Web Service Operation node on the Properties tab: 
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Property Value Comments 

Node ID GetAccountNum3270 A unique name that identifies the Web 

service operation. 

Web Service 

Operation 

GetAccountNum3270 The name that Web service clients will use 

to call this operation. 

Service Inputs (see comments) Define these values in the data collection 

dialog box*. 

Service Outputs (see comments) Define these values in the data collection 

dialog box*. 

Description Collect names from 

the 3270 screen, 

return credit limit 

and status. 

Appears in the WSDL as documentation for 

the Web service operation. 

After all properties are defined, save your changes and go to Task 3C. 

*AcctMain3270 data collection: Service Inputs (Web Service Operation node) 

The following instructions step you through the process of defining service inputs for the 

Web Service Operation node of the my_acctmain3270.ivp sample. 

After you place the Web Service Operation node on the diagram, you must define the 

service inputs. 

a) Click the Service Inputs label to reveal the ellipsis  button. 

b) Click  to display the Create Service Inputs dialog box. 

c) Click Add. 

 

d) Type lastName in the box to identify the service input and press ENTER or click 

outside the box. 

You do not need to change the default properties (in the right-hand pane). 

e) Click Add again to define another service input. 

f) Type firstName in the new box and press ENTER or click outside the box. 

You can accept the default properties. 

g) Click OK to save the service inputs and exit the Create Service Inputs dialog box. 
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*AcctMain3270 data collection: Service Outputs (Web Service Operation node) 

The following instructions step you through the process of defining service outputs for the 

Web Service Operation node of the my_acctmain3270.ivp sample. Your screen should look 

like the screen shot below when complete: 

 

The process to define the service outputs is the same as for defining the service inputs. 

a) Click the Service Outputs label to reveal the ellipsis  button. 

b) Click  to open the Create Service Outputs dialog box. 

c) Click Add. 

d) In this case, the service output is account information, so type AccountInfo in the 

box and press ENTER, or click outside the box. 

e) Set the Data Type to Complex Type. 

Note: You will define the remaining data objects as children of this parent. 

f) With AccountInfo highlighted in the left pane, click Add again to define another 

service output (a child of the parent object). 

g) Type firstName in the box and press ENTER, or click outside the box. 

You can accept the default properties. 

h) Click Add again to define another service output, and type lastName in the box 

below FirstName. 

You can accept the default properties. 

i) Click Add again to define another service output, and type title in the box. 

You can accept the default properties. 

j) Click Add again to define another service output, and type creditLimit in the 

box. 

You can accept the default properties. 

k) Click Add again to define another service output, and type status in the box. 

You can accept the default properties. 

l) Click Add again to define another service output, and type accountNum in the box. 

You can accept the default properties. 
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m) Click Add again to define another service output, and type message in the box. 

You can accept the default properties. 

n) Click OK to save the service outputs and exit the Create Service Outputs dialog 

box. 

AcctMain3270 Task 3C: Add a 3270 Process Node 

The 3270 Process node defines the information needed to start the LINK 3270 Bridge, such as 

the transaction code and initial processing values. (Learn more about Ivory 3270 Process 

nodes) 

1. Drag a 3270 Process node from the Toolbox tab onto the diagram and connect it to the 

Web Service Operation node. 

Tip: To connect two nodes, click the first node then Shift+Click the second node. 

2. Define the 3270 Process node on the Properties tab: 

Property Value Comments 

Node ID Trancode IVYS-Press Enter A unique name that identifies the 

node. 

Initial Trans ID  IVYS   

If you are going to deploy this sample project to a platform other than CICS, see your 

Administrator for EXCI and ECI settings. 

After all properties are defined, save your changes and go to Task 3D. 

AcctMain3270 Task 3D: Add a 3270 Point Node 

This 3270 Point node identifies the BMS mapset for the transaction code defined by the 3270 

Process. (Learn more about Ivory 3270 Point nodes) 

1. Drag a 3270 Point node from the Toolbox tab onto the diagram and connect it to the 

3270 Process node. 

2. Define the 3270 Point node on the Properties tab: 

Property Value Comments 

Node ID MainMenu Enter a unique name that identifies the node. 

Mapset File giismma.ivb Select from the drop-down list. 

Map MAINMNU Select from the drop-down list. 

After all properties are defined, save your changes and go to Task 3E. 

AcctMain3270 Task 3E: Add a Move to 3270 Node 

This Move to 3270 node enables the movement of data from any source that was defined at a 

higher level than this node. (Learn more about Ivory Move to 3270 nodes) 

1. Drag a Move to 3270 node from the Toolbox tab onto the diagram and connect it to the 

3270 Point node. 
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2. Define the Move to 3270 node on the Properties tab: 

Property Value Comments 

Node ID Move last/first names Enter a unique name that identifies the 

node. 

Data Movements (see comments) Define these values in the data 

collection dialog box*. 

After all properties are defined, save your changes and go to Task 3F. 

*AcctMain3270 data collection: Data Movements (Move to 3270 node) 

The following instructions step you through the process of defining the Move to 3270 data 

movements for the my_acctmain3270.ivp sample. 

Your screen should look like the screen shot below when complete: 

 

a) Click the Data Movements label to reveal the ellipsis  button. 

b) Click  to open the Create Data Movements to Node”MainMenu” dialog box. 

c) Click Add to display the Choose Field dialog. 

d) Double-click to select LASTNAMEMAIN. 

e) In the Move From pane, select a Data Source Type of Service Input. Then from 

the Data Source tree view pane (lower right), click to select the corresponding 

service input; in this case, select lastName. Ivory automatically fills the Service 

Input field in the Move From pane. 

f) Click Add to display the Choose Field dialog again. 

g) Double-click to select FIRSTNAMEMAIN. 

h) In the Move From pane, define a Data Source Type of Service Input. Then from 

the Data Source tree view pane (lower right), click to select the corresponding 

service input; in this case, select firstName. Ivory automatically fills the Service 

Input field in the Move From pane. 

i) Click OK to save the data movements and exit the dialog box. 
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AcctMain3270 Task 3F: Add a 3270 Action Node 

This 3270 Action node identifies the action (AID key) required to display the next screen. 

(Learn more about Ivory 3270 Action nodes) 

1. Drag a 3270 Action node from the Toolbox tab onto the diagram and connect it to the 

Move to 3270 node. 

2. Define the 3270 Action node on the Properties tab: 

Property Value Comments 

Node ID Press Enter Enter a unique name that identifies the node. 

After all properties are defined, save your changes and go to Task 3G. 

AcctMain3270 Task 3G: Add a 3270 Point Node 

This 3270 Point node identifies the BMS mapset for the transaction code defined by the 3270 

Process. (Learn more about Ivory 3270 Point nodes) 

1. Drag a 3270 Point node from the Toolbox tab onto the diagram and connect it to the 

3270 Action node. 

2. Define the 3270 Point node on the Properties tab: 

Property Value Comments 

Node ID MainMenu2 Enter a unique name that identifies the node. 

Mapset File giismma.ivb Select from the drop-down list. 

Map MAINMNU Select from the drop-down list. 

After all properties are defined, save your changes and go to Task 3H. 

AcctMain3270 Task 3H: Add a Move to Output Node 

This Move to Output node defines the data fields that will be returned in the service response. 

Any data previously collected can be marked as information to include in the service response. 

The WSDL output fields are the only method to return data to the requesting application. (Learn 

more about Ivory Move to Output nodes) 

1. Drag a Move to Output node from the Toolbox tab onto the diagram and connect it to the 

3270 Point node. 

2. Define the Move to Output node on the Properties tab: 

Property Value Comments 

Node ID Save Account 

Number 
Enter a unique name that identifies the node. 

Service Output 

Data Movements 

(see comments) Define these values in the data collection dialog 

box*. 

After all properties are defined, save your changes and go to Task 3I. 
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*AcctMain3270 data collection: Service Output Data Movements (Move to Output node-Save 
Account Number) 

The following instructions step you through the process of defining the Move to Output 

(Save Account Number) data movements for the my_acctmain3270.ivp sample. 

Your screen should look like the screen shot below when complete: 

 

a) Click the Service Output Data Movements label to reveal the ellipsis  button. 

b) Click  to open the Create Data Movements to Service Outputs dialog box. 

c) Click Add. 

Another dialog box opens, listing the fields in the BMS mapset (defined in the 3270 

Point node). 

d) Click  beside AccountInfo to expand the list. 

e) Select all of the service outputs for AccountInfo and click OK. 

Tip: Click the first item then Shift+Click the last item. 

f) Select the AccountInfo.firstName field in the Move To list and define it as 

follows: 

Data Source Type Select 3270 Field from the drop-down list. 

3270 Point Node Select MainMenu2 from the drop-down list. 

3270 Field Select SRCHFIRST under GIISMBM.MAINMNU in the Data 

Source tree view (lower right-hand pane). 
 

g) Select the AccountInfo.lastName field in the list and define it as follows: 
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Data Source Type Select 3270 field from the drop-down list. 

3270 Point Node Select MainMenu2 from the drop-down list. 

3270 Field Select SRCHLAST under GIISMBM.MAINMNU in the Data 

Source tree view. 
 

h) Select the AccountInfo.title field in the list and define it as follows: 

Data Source Type Select 3270 field from the drop-down list. 

3270 Point Node Select MainMenu2 from the drop-down list. 

3270 Field Select SRCHTITLE under GIISMBM.MAINMNU in the Data 

Source tree view. 
 

i) Select the AccountInfo.creditLimit field in the list and define it as follows: 

Data Source Type Select 3270 field from the drop-down list. 

3270 Point Node Select MainMenu2 from the drop-down list. 

3270 Field Select SRCHLIMIT under GIISMBM.MAINMNU in the Data 

Source tree view. 
 

j) Select the AccountInfo.status field in the list and define it as follows: 

Data Source Type Select 3270 field from the drop-down list. 

3270 Point Node Select MainMenu2 from the drop-down list. 

3270 Field Select SRCHSTATUS under GIISMBM.MAINMNU in the Data 

Source tree view. 
 

k) Select the AccountInfo.accountNum field in the list and define it as follows: 

Data Source Type Select 3270 field from the drop-down list. 

3270 Point Node Select MainMenu2 from the drop-down list. 

3270 Field Select SRCHACCT under GIISMBM.MAINMNU in the Data 

Source tree view. 
 

l) Select the AccountInfo.message field in the list and define it as follows: 

Data Source Type Select 3270 field from the drop-down list. 

3270 Point Node Select MainMenu2 from the drop-down list. 

3270 Field Select MSGM under GIISMBM.MAINMNU in the Data Source 

tree view. 
 

After you have selected and defined the fields, click OK to close the Create Data 

Movements dialog box. 
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AcctMain3270 Task 3I: Add a Decision Node 

The Decision node directs the flow of the Web service. It can be used to find errors, end a 

process, or select the next operation. This Decision node checks a status code and returns the 

details for the status. (Learn more about Ivory Decision nodes) 

The Decision Node has two outgoing connections. By default, the left connection is taken if the 

comparison evaluates to False (no), and the right connection is taken if the comparison 

evaluates to True (yes). You can swap the left and right connections using the context menu 

item Swap Port Sides. 

Before we begin adding the first of three decision nodes, take a look at the graphic below that 

depicts one way to arrange the next few nodes: 

 

1. Drag a Decision node from the Toolbox tab onto the diagram and connect it to the Move 

to Output node. 

2. Define the Decision node on the Properties tab: 

Property Value Comments 

Node ID StatusActive Enter a unique name that identifies the node. 

1st Operand (see comments) This field is automatically filled after you define 

the data source type and value. 

Data Source 

Type 

3270 Field Select from the drop-down list.  

3270 Point Node MainMenu2 Select from the drop-down list.  

3270 Field SRCHSTATUS Select from dialog box listing fields from map 

defined in MainMenu2. 

Comparison 

Operator 

Equal To Select from the drop-down list. 
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Property Value Comments 

2nd Operand (see comments) This field is automatically filled after you define 

the data source type and value. 

Data Source 

Type 

Static Text Select from the drop-down list.  

Static Text Value A This field is case-sensitive.  

After all properties are defined, save your changes and go to Task 3J. 

AcctMain3270 Task 3J: Add a Move to Output Node 

This Move to Output node defines the data fields that will be returned in the service response. 

Any data previously collected can be marked as information to include in the service response. 

(Learn more about Ivory Move to Output nodes) 

1. Drag a Move to Output node from the Toolbox tab onto the diagram to the right (yes 

side) of the StatusActive decision node and connect it to the StatusActive decision node. 

2. Define the Move to Output node on the Properties tab: 

Property Value Comments 

Node ID Active Enter a unique name that identifies the node. 

Service Output 

Data 

Movements 

(see comments) Define these values in the data collection dialog 

box*. 

After all properties are defined, save your changes and go to Task 3K. 

*AcctMain3270 data collection: Service Output Data Movements (Move to Output node-Active) 

The following instructions step you through the process of defining the Move to Output (Active) 

data movements for the my_acctmain3270.ivp sample. 

a) Click the Service Output Data Movements label to reveal the ellipsis  button. 

b) Click  to open the Create Data Movements to Service Outputs dialog box. 

c) Click Add. 

Another dialog box opens, listing the fields from the Web Service Operation 

(GetAccountNum) node. 

d) Click  to expand the list. 

e) Select status and click OK. 

The Choose Field dialog box closes, and the Status output appears in the Move To 

pane on the left side of the Create Data Movements dialog box. 

f) Define the Status data element: 

Data Source Type Select Static Text from the drop-down list. 

Static Text Type A (Active). This field is case-sensitive. 
 

g) Click OK to close the Create Data Movements dialog box. 
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AcctMain3270 Task 3K: Add a Decision Node 

This Decision node checks a status code and returns the details for the status. (Learn more 

about Ivory Decision nodes) 

1. Drag another Decision node from the Toolbox tab onto the diagram and connect it to the 

left (no) connector of the StatusActive Decision node. 

2. Define the second Decision node on the Properties tab: 

Property Value Comments 

Node ID StatusInactive Enter a unique name that identifies the node. 

1st Operand (see comments) This field is automatically filled after you define 

the data source type and value. 

Data Source 

Type 

3270 Field Select from the drop-down list.  

3270 Point 

Node 

MainMenu2 Select from the drop-down list.  

3270 Field SRCHSTATUS Select from dialog box listing fields from map 

defined in MainMenu2. 

Comparison 

Operator 

Equal To Select from the drop-down list. 

2nd Operand (see comments) This field is automatically filled after you define 

the data source type and value. 

Data Source 

Type 

Static Text Select from the drop-down list. 

Static Text 

Value 

I This field is case-sensitive.  

After all properties are defined, save your changes and go to Task 3L. 

AcctMain3270 Task 3L: Add a Move to Output Node 

1. Drag a Move to Output node from the Toolbox tab onto the diagram and connect it to the 

right (yes) connector of the StatusInactive Decision node. 

2. Define the second Move to Output node on the Properties tab: 

Property Value Comments 

Node ID Inactive Enter a unique name that identifies the node. 

Service Output 

Data 

Movements 

(see comments) Define these values in the data collection dialog 

box*. 

After all properties are defined, save your changes and go to Task 3M. 
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*AcctMain3270 data collection: Service Output Data Movements (Move to Output node-Inactive) 

The following instructions step you through the process of defining the Move to Output 

(Inactive) data movements for the my_acctmain3270.ivp sample. 

Define the data movements for the Move to Output (Inactive) node. 

a) Click the Service Output Data Movements label to reveal the ellipsis  button. 

b) Click  to open the Create Data Movements to Service Outputs dialog box. 

c) Click Add. 

Another dialog box opens, listing the fields from the Web Service Operation 

(GetAccountNum) node. 

d) Click  to expand the list. 

e) Select status and click OK. 

The Choose Field dialog box closes, and the Status output appears in the left pane 

of the Create Data Movements dialog. 

f) Define the Status data element: 

Data Source Type Select Static Text from the drop-down list. 

Static Text Type I (Inactive). This field is case-sensitive. 
 

g) Click OK to close the Create Data Movements dialog box. 

AcctMain3270 Task 3M: Add a Decision Node 

Like the previous Decision node, this node checks a status code and returns the details for the 

status. 

1. Drag another Decision node from the Toolbox tab onto the diagram and connect it to the 

left (no) connector of the StatusInactive Decision node. 

2. Define the third Decision node on the Properties tab: 

Property Value Comments 

Node ID StatusClosed Enter a unique name that identifies the node. 

1st Operand (see comments) This field is automatically filled after you define 

the data source type and value. 

Data Source 

Type 

3270 Field Select from the drop-down list.  

3270 Point Node MainMenu2 Select from the drop-down list.  

3270 Field SRCHSTATUS Select from dialog box listing fields from map 

defined in MainMenu2. 

Comparison 

Operator 

Equal To Select from the drop-down list. 

2nd Operand (see comments) This field is automatically filled after you define 

the data source type and value. 
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Property Value Comments 

Data Source 

Type 

Static Text Select from the drop-down list. 

Static Text 

Value 

C This field is case-sensitive.  

After all properties are defined, save your changes and go to Task 3N. 

AcctMain3270 Task 3N: Add a Move to Output Node 

1. Drag a Move to Output node from the Toolbox tab onto the diagram and connect it to the 

right (yes) connector of the StatusClosed Decision node. 

2. Define the Move to Output node on the Properties tab: 

Property Value Comments 

Node ID Closed Enter a unique name that identifies the node. 

Service Output 

Data 

Movements 

(see comments) Define these values in the data collection dialog 

box*. 

After all properties are defined, save your changes and go to Task 3O. 

*AcctMain3270 data collection: Service Output Data Movements (Move to Output node-Closed) 

The following instructions step you through the process of defining the Move to Output 

(Closed) data movements for the my_acctmain3270.ivp sample. 

a) Click the Service Output Data Movements label to reveal the ellipsis  button. 

b) Click  to open the Create Data Movements to Service Outputs dialog box. 

c) Click Add. 

Another dialog box opens, listing the fields from the Web Service Operation 

(GetAccountNum) node. 

d) Click  to expand the list. 

e) Select status and click OK. 

The Choose Field dialog box closes, and the Status output appears in the left pane 

of the Create Data Movements dialog. 

f) Define the Status data element: 

Data Source Type Select Static Text from the drop-down list. 

Static Text Type C (Closed). This field is case-sensitive. 
 

g) Click OK to close the Create Data Movements dialog box. 

AcctMain3270 Task 3O: Add a Move to Output Node 

1. Drag another Move to Output node from the Toolbox tab onto the diagram and connect it 

to the left (no) connector of the StatusClosed Decision node. 
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2. Define the Move to Output node on the Properties tab: 

Property Value Comments 

Node ID Unknown Enter a unique name that identifies the node. 

Service Output 

Data 

Movements 

(see comments) Define these values in the data collection dialog 

box*. 

After all properties are defined, save your changes and go to Task 3P. 

*AcctMain3270 data collection: Service Output Data Movements (Move to Output node-
Unknown) 

The following instructions step you through the process of defining the Move to Output 

(Unknown) data movements for the my_acctmain3270.ivp sample. 

a) Click the Service Output Data Movements label to reveal the ellipsis  button. 

b) Click  to open the Create Data Movements to Service Outputs dialog box. 

c) Click Add. 

Another dialog box opens, listing the fields from the Web Service Operation 

(GetAccountNum) node. 

d) Click  to expand the list. 

e) Select status and click OK. 

The Choose Field dialog box closes, and the Status output appears in the left pane 

of the Create Data Movements dialog. 

f) Define the Status data element: 

Data Source Type Select Static Text from the drop-down list. 

Static Text Type U (Unknown). This field is case-sensitive. 
 

g) Click OK to close the Create Data Movements dialog box. 

AcctMain3270 Task 3P: Add a Connector Node 

The Connector node is a utility function to create a connection point in the logic flow. A 

connector can bring multiple input connections into a single output connection. (Learn more 

about Ivory Connector nodes) 

1. Drag a Connector node from the Toolbox tab onto the diagram and connect it to all four 

of the Move to Output nodes. 

2. Define the Connector node on the Properties tab. 

Property Value Comments 

Node ID MainLineConnector Enter a unique name that identifies the node. 

After all properties are defined, save your changes and go to Task 3Q. 
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AcctMain3270 Task 3Q: Add a 3270 Action Node 

This 3270 Action node shows the end of this application flow. (Learn more about Ivory 3270 

Action nodes) 

1. Drag a 3270 Action node from the Toolbox tab onto the diagram and connect it to the 

Connector node. 

2. Define the 3270 Action node on the Properties tab: 

Property Value Comments 

Node ID Press Clear Enter a unique name that identifies the node. 

3270 AID Key Clear Select the AID key to be issued during the 

processing of the current Action node. 

After all properties are defined, save your changes and go to Task 3R. 

AcctMain3270 Task 3R: Add an Operation End Node 

The Operation End node signals Ivory Server that there is no additional processing to perform. 

This will fire the service response from the server. (Learn more about Ivory Operation End 

nodes) 

1. Drag an Operation End node from the Toolbox tab onto the diagram below the 3270 

Action node and connect the 3270 Action node to the Operation End node. 

2. Define the Operation End node on the Properties tab: 

Property Value Comments 

Node ID Complete Enter a unique name that identifies the node. 
 

3. The diagram is complete. Save the changes to the project. 

Your project diagram should resemble the diagram of the AcctMain3270 sample supplied with 

Ivory (in the \Samples folder). 

The next step is to build the Web service and generate the WSDL document. 

AcctMain3270 Task 4: Build Web Service and Generate WSDL Document 

After you've finished modeling the new Web service operation, you're ready to build it and 

generate the WSDL document. 

1. From the Ivory menu, select Tools> Build. 

o The Output window shows the Build Process Summary. Click the Output tab at the 

bottom of the screen to see the summary. 

After a successful build, the Output window displays the message Build Complete. If 

there are errors, you will see the message Build Complete With Errors. 

The summary provides a brief description of the Web service operation(s) in the 

project, including the location of the WSDL document(s). The build summary is not 

saved; if you need to view the build summary again, you can re-run the build process. 

o The WSDL document is generated. 
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This WSDL document is saved using the project name and the WSDL file extension. Go 

to the Explorer window and click the Refresh  button to see the WSDL file. 

o An HTML file is generated. 

This HTML file describes the contents of the WSDL document, including the Web service 

name and description, Web service operation name and description, the input/output 

parameters, and a description of complex data types. 

This HTML file is saved using the project name with an HTML file extension. Go to the 

Explorer window and click the Refresh  button to see the HTML file. If this filename 

does not appear in the Explorer window, click the Show All Files button. 

Next you will deploy the project. 

AcctMain3270 Task 5: Deploy the Project 

After you successfully build an Ivory project, you can deploy it to Ivory Server. You must 

deploy the project before you can test it. 

In order to deploy the project, you must have an FTP profile. You can use the FTP profile that 

you created for the AcctMain sample, or you can create a new FTP profile. 

1. From the Ivory menu bar, select File> Deploy Project to Server. 

You'll see a list of existing FTP profiles. 

2. Choose the FTP profile for the Ivory Server where you want to deploy the project, or 

create a new FTP profile. 

After you select an FTP profile, Ivory will select and upload the necessary files for the project 

being deployed, including the server instructions, maps, copybooks, and WSDL documents. 

When the process is complete, Ivory displays the messages Upload Complete and Deploy To 

Server Complete. 

If the upload is not successful, the FTP status messages are sent to the output window to 

help you resolve the problem. 

The files are uploaded to the URI location defined in the Start node of the project diagram, into 

a folder named WebServices and a subfolder using the project name. For example, if you have 

a project that defines the Start node URI as http: //dev.gtsoftware.com: 8001/soap/apps/accts 

then Ivory deploys the project files to the /WebServices/soap/apps/accts folder. 

By default, Ivory Server treats any URI that begins with "soap" as a Web service rather than 

an HTML request. 

The final step is to test the new Web service operation. 

AcctMain3270 Task 6: Test the Web Service Operation 

After you deploy an Ivory project, you should test it. 

The Ivory FTP Server and the Ivory CICS TCPIPSERVICE must be active in order to run the 

Web service operation. 

1. From the Ivory menu bar, select Tools> Test to open the Test document window. 

http://dev.gtsoftware.com:8001/soap/apps/accts
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2. Click Request to open the Request dialog box. 

The tree view lists the service inputs for the GetAccountNum request (defined in the Web 

Service Operation node). In this case, the service inputs are lastName and firstName. 

3. Click lastName. 

In the right-hand pane, you'll see information about the data element. 

4. Place the cursor in the Value field and type SMITH. 

5. Click firstName, and type STEVE in the Value field. 

6. Click OK. 

The Request dialog box closes and you'll see the resulting XML code in the Request. 

<?xml version="1.0" encoding="utf-16"?> 

<soap: Envelope xmlns: xsi="http: //www.w3.org/2001/XMLSchema-instance" 

xmlns: xsd="http: //www.w3.org/2001/XMLSchema" xmlns: soapenc="http: 

//schemas.xmlsoap.org/soap/encoding/" xmlns: s0="urn: Name2AccountNumber" 

xmlns: soap="http: //schemas.xmlsoap.org/soap/envelope/"> 

<soap: Body soapenc: encodingStyle="http: 

//schemas.xmlsoap.org/soap/encoding/"> 

<GetAccountNum3270> 

<LastName>smith</LastName> 

<FirstName>steve</FirstName> 

</GetAccountNum3270> 

</soap: Body> 

</soap: Envelope> 

7. Click Test to generate the Response. 

<?xml version="1.0" encoding="utf-8"?> 

<soap: Envelope xmlns: soap="http: //schemas.xmlsoap.org/soap/envelope/" 

xmlns: xsi="http: //www.w3.org/2001/XMLSchema-instance" xmlns: xsd="http: 

//www.w3.org/2001/XMLSchema" xmlns: SOAP-ENC="http: 

//schemas.xmlsoap.org/soap/encoding/"> 

<soap: Body> 

<GetAccountNum3270Response> 

<AccountInfo> 

<Message xsi: type="xsd: string">01 record(s) found </Message> 

<Title xsi: type="xsd: string">MR </Title> 

<AccountNum xsi: type="xsd: string">10001</AccountNum> 

<CreditLimit xsi: type="xsd: string"> 1000.00</CreditLimit> 

<Status xsi: type="xsd: string">Active</Status> 

<FirstName xsi: type="xsd: string">STEVE</FirstName> 

<LastName xsi: type="xsd: string">SMITH</LastName> 

</AccountInfo> 

</GetAccountNum3270Response> 

</soap: Body> 

</soap: Envelope> 

8. You can click Response to open the Response dialog box. Use the tree view to display the 

individual data elements of the service outputs: firstName, lastName, title, creditLimit, 

status, accountNum, and message. 

You'll see that the service input (lastName Smith, firstName Steve) returns the following 

service outputs: Title=MR, Account Number=10001, Credit Limit=1000.00, and 

Status=Active. 
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To verify that the information you're getting is accurate, you can open an emulator window 

(Tools> Emulator), log on to the mainframe and verify the results. 

You have completed the AcctMain3270 sample project—congratulations! The next 

Sample Project is AcctMainEWS.  
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Sample Project: AcctMainEWS 
This sample Web service is similar to the AcctMain3270 sample, but the status data is collected 

from a Web service rather than using Ivory Decision nodes. 

This sample Ivory project will process a 3270 BMS application and call an external Web service. 

The target 3270 BMS is invoked by the IVYS transaction code. The data is collected from the 

3270 BMS map using the BMS meta data, and then the code from the BMS data is used as 

input to the Web service AccountStatus. 

Important: Complete the AcctMain and AcctMain3270 samples before you attempt this 

sample. Many important concepts that are explained in those samples are not repeated here. 

The process of creating a new Web service operation follows these steps: 

1. Create the Ivory project. 

2. Import BMS mapsets and COBOL copybooks. 

3. Model (diagram) the new Web service and define the component properties. 

4. Build the Web service, and generate the server instructions and WSDL document. 

5. Deploy the project to Ivory Server. 

6. Test the new Web service operation(s). 
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A diagram of the completed project is shown below: 

 

Begin by creating the project file. 

AcctMainEWS Task 1: Create the Project File 

To begin, you'll identify a location for the project files and identify a project name. 

A sample AcctMainEWS project is supplied with Ivory. Using the names specified below, you 

can create your own project without modifying the supplied files. 

1. Start Ivory Studio. (From the Start menu, select Programs> GT_Software> Ivory 

Studiox.x> Ivory Studio.) 

2. Select File> New Project> New Web Service Project> SOAP to open a Windows 

Explorer dialog box. 

3. Navigate to the Ivory Tutorial folder that you created for the first tutorial project and 

create a subfolder named qs_acctmainews. 
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4. Open the new subfolder and in the File name field, type my_acctmainews for the new 

project. 

Note: Ivory will automatically append “.ivp" to the file name. 

5. Click Open and a blank Ivory project is created. 

The next step is to import BMS mapsets and COBOL copybooks. 

AcctMainEWS Task 2: Import the BMS Mapsets and COBOL Copybooks 

The next step is to import the resources you need for the project: BMS mapsets, COBOL 

copybooks, or both. For this project, you'll need to import a BMS mapset, which is provided 

with the Ivory installation. 

1. From the Ivory menu bar, select File> Import BMS Mapset> Select File. 

2. Navigate to the location where the BMS mapset resides: in this case, it's the 

\Ivory_Studio\versionx.x\Samples\Ivory_Projects\CICS\AcctMainEWS folder. 

Note: You can import a mapset or copybook from any networked location. If the mapset or 

copybook is not on a networked drive, you must use FTP to transfer it to your PC. 

3. Select the mapset named GIISMMA.map and click Open. This will copy the mapset into 

the project folder and include it in the project. The mapset appears in the Explorer under 

its original name with an .ivb file extension. 

The next step is to model the new Web service operation and define the component properties. 

AcctMainEWS Task 3: Model the Web Service Operation 

Now that you've defined the project and imported the mapset, you're ready to begin modeling 

the new Web service operation. 

Accept the default value for any node properties that are not specifically defined in these 

instructions. 

You should have Ivory Studio running with the Explorer, Toolbox, and Properties windows open. 

1. Select the Toolbox tab to display the component nodes, and then click the All group to 

display all Ivory diagram nodes. 

Begin by adding a Start node. 

AcctMainEWS Task 3A: Add a Start Node 

1. Drag a Start node onto the Diagram window and define the properties as follows: 

Property Value Comments 

Node ID AccountMainEWS  

Web Service 

Name 

AccountMainEWS The Web service can be the same as the 

project name. 
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Property Value Comments 

URI (see comments) Specify the DNS name or IP address and 

port where Ivory Server is running; contact 

your Ivory administrator for assistance. 

Note: It is recommended that a URI prefix 

be entered in the FTP Server Profile and be 

prepended during deploy. In this case, the 

Use URI Prefix During Deploy field needs to 

be set to True in the Advanced Properties. 

WSDL Location (see comments) By default, this is the URI location, 

followed by "?WSDL". Change it only if you 

are using a different location for WSDL 

discovery; contact your Ivory administrator 

for assistance. 

Web Service 

Description 

Sample to execute 

a 3270 application 

using the CICS 

Link3270 

processing. 

Appears in the WSDL as documentation for 

the Web service. 

After all properties are defined, save your changes and go to Task 3B. 

AcctMainEWS Task 3B: Add a Web Service Operation Node 

1. Drag a Web Service Operation node onto the Diagram window; Ivory automatically 

connects it to the Start node. 

Define the node properties as follows: 

Property Value Comments 

Node ID AccountStatus  

Web Service 

Operation 

GetAccountStatus Specify the name that Web service clients 

will use to call this operation. 

Service Inputs (see comments) Define these values in the data collection 

dialog box*. 

Service Outputs (see comments) Define these values in the data collection 

dialog box*. 

Description Collect data from 

3270 application, 

then call a Web 

service to provide 

an account 

description. 

Appears in the WSDL as documentation for 

the Web service operation. 

After all properties are defined, save your changes and go to Task 3C. 
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*AcctMainEWS data collection: Service Inputs (Web Service Operation node) 

After you place the Web Service Operation node on the my_acctmainews.ivp diagram, you 

must define the service inputs. 

a) Click the Service Inputs label to reveal the ellipsis  button, and then click  to 

display the Create Service Inputs dialog box. 

b) Click Add. 

c) To identify the service input, type name in the box and press ENTER. 

d) Set the Data Type to Complex Type. 

Note: You will define the remaining data objects as children of this parent. 

e) Add a service input, named first, as a child of the name object. Accept the 

default properties. 

f) Add a service input, named last, as a child of the name object. Accept the default 

properties. 

g) Click OK to save the service inputs and exit the Create Service Inputs dialog box. 

*AcctMainEWS data collection: Service Outputs (Web Service Operation node) 

The process to define the service outputs is the same as for defining the service inputs. 

a) Click the Service Outputs label to reveal the ellipsis  button, and then click  

to open the Create Service Outputs dialog box. 

b) Click Add. 

c) To identify the service output, type acctInfo in the box and press ENTER. 

d) Set the Data Type to Complex Type. 

e) Add a service output, named name, as a child of the acctInfo object. 

f) Set the Data Type to Complex Type. 

g) Add the following service outputs as children of the name object (accept the 

default properties): 

 title 

 first 

 last 

h) Add a service output, named account, as a child of the acctInfo object. 

i) Set the Data Type to Complex Type. 

j) Add the following service outputs as children of the account object (accept the 

default properties): 

 number 
 status 
 description 

k) Add a service output, named creditLimit, as a child of the acctInfo object. 

l) Define the object properties: 

Data Type decimal 

Decimal Constraints Both 

Length (displays if Decimal Contraints = Both) 7 

Decimal Digits (displays if Decimal Contraints = Both) 2 

When you've finished, your Create Service Outputs list should look like this: 
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m) Click OK to save the service outputs and exit the Create Service Outputs dialog 

box. 

AcctMainEWS Task 3C: Add a 3270 Process Node 

1. Drag a 3270 Process node onto the diagram and connect it to the Web Service Operation 

node. 

Define the node properties as follows: 

Property Value Comments 

Node ID Txn ID IVYS - 

Press Enter 
 

Initial Trans ID  IVYS Supplied IBM sample transaction. 

Note: If you are going to deploy this sample project to a platform other than CICS, see 

your Administrator for EXCI and ECI settings. 

After all properties are defined, save your changes and go to Task 3D. 

AcctMainEWS Task 3D: Add a 3270 Point Node 

1. Drag a 3270 Point node onto the diagram and connect it to the 3270 Process node. 

Define the node properties as follows: 

Property Value Comments 

Node ID MainMenu  

Mapset File giismma.ivb The name of BMS mapset to which this 

point node’s map belongs. 

Map MAINMNU The map name in the BMS mapset. 

After all properties are defined, save your changes and go to Task 3E. 

AcctMainEWS Task 3E: Add a Move to 3270 Node 

1. Drag a Move to 3270 node onto the diagram and connect it to the 3270 Point node. 

Define the node properties as follows: 
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Property Value Comments 

Node ID Move last/first 

names 
 

Data 

Movements 

(see comments) Define these values in the data collection 

dialog box*. 

After all properties are defined, save your changes and go to Task 3F. 

*AcctMainEWS data collection: Data Movements (Move to 3270 node) 

The following instructions step you through the process of defining the Move to 3270 data 

movements for the my_acctmainews.ivp sample. 

a) Click the Data Movements label to reveal the ellipsis  button. Click  to open 

the Create Data Movements to Node “MainMenu” dialog box. 

b) Click Add to display the Choose Field dialog. Select LASTNAMEMAIN and 

FIRSTNAMEMAIN. Click OK to close the Choose Field dialog. 

c) Select LASTNAMEMAIN in the Move To pane. In the Move From pane, define it 

with a Data Source Type of Service Input. Then from the Data Source tree view 

pane, select the corresponding service input; in this case, select last. Ivory 

automatically fills the service Input field in the Move From pane. 

d) Select FIRSTNAMEMAIN in the Move To pane. In the Move From pane, define it 

with a Data Source Type of Service Input. Then from the Data Source tree view 

pane, select the corresponding service input; in this case, select first. Ivory 

automatically fills the service Input field in the Move From pane. 

e) Click OK to save the data movements and exit the dialog box. 

AcctMainEWS Task 3F: Add a 3270 Action Node 

1. Drag a 3270 Action node onto the diagram and connect it to the Move to 3270 node. 

Define the node properties as follows: 

Property Value Comments 

Node ID Press Enter  

Default Trans 

ID  

IVYS The transaction ID to request if no 

transaction ID to use was specified by the 

prior transaction execution in CICS. 

After all properties are defined, save your changes and go to Task 3G. 

The diagram will branch after this node. 

AcctMainEWS Task 3G: Add a 3270 Point Node 

At this point the project is branching—both branches will begin with a 3270 Point Node. This 

task will start the left 3270 Point Node branch shown in the diagram example at the beginning 

of this sample project. 

1. Drag a 3270 Point node onto the diagram and connect it to the 3270 Action node. 

Define the node properties as follows: 
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Property Value Comments 

Node ID DetailMap  

Mapset File giismma.ivb The BMS mapset file to which this point 

node’s map belongs. 

Map DETAIL The map name in the BMS mapset. 

After all properties are defined, save your changes and go to Task 3H. 

AcctMainEWS Task 3H: Add a 3270 Action Node 

1. Drag a 3270 Action node onto the diagram and connect it to the 3270 Point node. 

Define the node properties as follows: 

Property Value Comments 

Node ID Clear Detail  

3270 AID Key Clear 3270 AID key to be issued during the 

processing of the current Action node. 

After all properties are defined, save your changes and go to Task 3I. 

AcctMainEWS Task 3I: Add an Operation End Node 

1. Drag an Operation End node onto the diagram and connect it to the 3270 Action node. 

Define the node properties as follows: 

Property Value Comments 

Node ID SOAP Fault  

Generate SOAP 

Fault 

True If this property is set to true, a SOAP fault 

will be generated if the OperationEnd node 

is reached. 

SOAP Fault 

Code 

999 The fault code to be used in the SOAP fault 

if “Generate Fault” is true and this 

Operation End node is reached. 

SOAP Fault 

String 

Should not occur – 

Wrong Map… 
The fault string to be used in the SOAP 

fault if “Generate Fault” is true and this 

Operation End node is reached. 

This Operation End node marks the end of one branch of the diagram. Now you'll begin the 

second branch of the diagram. 

After all properties are defined, save your changes and go to Task 3J. 

AcctMainEWS Task 3J: Add a 3270 Point Node 

This task will start the right 3270 Point Node branch shown in the diagram example at the 

beginning of this sample project. 
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1. Drag another 3270 Point node onto the diagram and connect it to the first 3270 Action 

node (Node ID "Press Enter"). 

Define the node properties as follows: 

Property Value Comments 

Node ID MainMenu2  

Mapset File giismma.ivb  

Map MAINMNU  

After all properties are defined, save your changes and go to Task 3K. 

AcctMainEWS Task 3K: Add a Move to Output Node 

1. Drag a Move to Output node onto the diagram and connect it to the (MainMenu2) 3270 

Point node. 

Define the node properties as follows: 

Property Value Comments 

Node ID Save Account 

Number 
 

Service Output 

Data Movements 

(see comments) Define these values in the data collection 

dialog box*. 

After all properties are defined, save your changes and go to Task 3L. 

*AcctMainEWS data collection: Service Output Data Movements (Move to Output node-Save 
Account Number) 

The following instructions step you through the process of defining the Move to Output 

(Save Account Number) data movements for the my_acctmainews.ivp sample. 

a) Click the Service Output Data Movements label to reveal the ellipsis  button. 

Click  to open the Create Data Movements to Service Outputs dialog box. 

b) Click Add. Another dialog box opens, listing the fields in the BMS mapset (defined 

in the 3270 Point node). Select the All Levels radio button. 

c) Select the following service outputs for acctInfo, and click OK. 

 acctInfo.name.title 

 acctInfo.name.first 

 acctInfo.name.last 

 acctInfo.account.number 

 acctInfo.account.status 

 acctInfo.creditLimit 

d) Select acctInfo.name.title from the Move To list and define it as follows: 

Data Source Type 3270 field 

3270 Point Node MainMenu2 

3270 Field SRCHTITLE 
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e) Select acctInfo.name.first from the Move To list and define it as follows: 

Data Source Type 3270 field 

3270 Point Node MainMenu2 

3270 Field SRCHFIRST 
 

f) Select acctInfo.name.last from the list and define it as follows: 

Data Source Type 3270 field 

3270 Point Node MainMenu2 

3270 Field SRCHLAST 
 

g) Select acctInfo.account.number from the list and define it as follows: 

Data Source Type 3270 field 

3270 Point Node MainMenu2 

3270 Field SRCHACCT 
 

h) Select acctInfo.account.status from the list and define it as follows: 

Data Source Type 3270 field 

3270 Point Node MainMenu2 

3270 Field SRCHSTATUS 
 

i) Select acctInfo.creditLimit from the list and define it as follows: 

Data Source Type 3270 field 

3270 Point Node MainMenu2 

3270 Field SRCHLIMIT 
 

j) After you have selected and defined the fields, click OK to close the Create Data 

Movements dialog box. 

AcctMainEWS Task 3L: Add a 3270 Action Node 

1. Drag a 3270 Action node onto the diagram and connect it to the Move to Output node. 

Define the node properties as follows. 

Property Value Comments 

Node ID Clear to End  

3270 AID Key  Clear  

After all properties are defined, save your changes and go to Task 3M. 
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AcctMainEWS Task 3M: Add a Decision Node 

1. Drag a Decision node onto the diagram and connect it to the 3270 Action node. 

Define the node properties as follows: 

Property Value Comments 

Node ID Call Web 

Service? 
 

1st Operand  This field is automatically filled after you define 

the data source type and value. 

Data Source Type 3270 Field  

3270 Point Node MainMenu2  

3270 Field MSGM Select from dialog box listing fields from map 

defined in MainMenu2. 

Comparison 

Operator 

Equal To 

Ignore Case 
 

2nd Operand  This field is automatically filled after you define 

the data source type and value. 

Data Source Type Static Text  

Static Text Value 01 record(s) 

found 
This field is case-sensitive. 

After all properties are defined, save your changes and go to Task 3N. 

AcctMainEWS Task 3N: Add an Operation End Node 

1. Drag an Operation End node onto the diagram and connect it to the No connector of the 

Decision node. 

Define the node properties as follows: 

Property Value Comments 

Node ID Invalid 

Account 
 

Generate SOAP 

Fault 

True  

SOAP Fault Code 111  

SOAP Fault String Invalid name; 

please supply 

First and Last 

Name 

 

After all properties are defined, save your changes and go to Task 3O. 
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AcctMainEWS Task 3O: Add a Web Service Client Point Node 

1. Drag a Web Service Client Point node onto the diagram and connect it to the Yes 

connector of the Decision node. 

Define the node properties as follows: 

Property Value Comments 

Node ID Web Service 

Verify 
  

WSDL Location  (see comments) The URI from which to obtain the WSDL 

document for this Web service. 

Click  to display the Set WSDL Location dialog 

box and then click Browse. Navigate to and 

select the supplied WSDL 

<Samples\Ivory_Projects\CICS\AccountMainEW

S\accountStatus.wsdl>. 

Web Service    Automatically filled after you specify the WSDL 

Location. 

URI   Automatically filled after you specify the WSDL 

Location. 

Web Service 

Operation  

  Automatically filled after you specify the WSDL 

Location. 

Service Inputs    Automatically filled after you specify the WSDL 

Location. 

Service Outputs    Automatically filled after you specify the WSDL 

Location. 

After all properties are defined, save your changes and go to Task 3P. 

AcctMainEWS Task 3P: Add a Move to Web Service Client Node 

1. Drag a Move to Web Service Client node onto the diagram and connect it to the Web 

Service Client Point node. 

Define the node properties as follows: 

Property Value Comments 

Node ID Input for WS 

Call 
  

Data Movements (see comments) Define these values in the data collection 

dialog box*. 

After all properties are defined, save your changes and go to Task 3Q. 

*AcctMainEWS data collection: Data Movements (Move to Web Service Client node) 

The following instructions step you through the process of defining the Move to Web 

Service Client data movements for the my_acctmainews.ivp sample. 
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a) Click the Data Movements label to reveal the ellipsis  button. Click  to open 

the Create Data Movements to Service Inputs dialog box. 

b) Click Add. Another dialog box opens, listing the fields from the Web Service Client 

Point node. 

c) Select accountStatusCode and click OK. The Choose Field dialog box closes, and 

the Status output appears in the left pane of the Create Data Movements dialog. 

d) Define the accountStatusCode data element: 

Data Source Type 3270 field 

3270 Point Node MainMenu2 

3270 Field SRCHSTATUS 

e) Click OK to close the Create Data Movements dialog box. 

Save the changes to the project (File> Save Project or press CTRL+S). 

AcctMainEWS Task 3Q: Add an Execute Web Service Client Node 

1. Drag an Execute Web Service Client node onto the diagram and connect it to the Move 

to Web Service Client node. 

Define the node properties as follows: 

Property Value Comments 

Node ID WS Call   

After all properties are defined, save your changes and go to Task 3R. 

AcctMainEWS Task 3R: Add a Move to Output Node 

1. Drag a Move to Output node onto the diagram and connect it to the Execute Web Service 

Client node. 

Define the node properties as follows: 

Property Value Comments 

Node ID Move   

Service Output 

Data Movements 

(see comments) Define these values in the data collection 

dialog box*. 

After all properties are defined, save your changes and go to Task 3S. 

*AcctMainEWS data collection: Service Output Data Movements (Move to Output node-Move) 

The following instructions step you through the process of defining the Move to Output 

(Move) data movements for the my_acctmainews.ivp sample. 

a) Click the Service Output Data Movements label to reveal the ellipsis  button. 

Click  to open the Create Data Movements to Service Outputs dialog box. 

b) Click Add. 

Another dialog box opens, listing the service outputs from the Web Service 

Operation node. 
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c) Select the All Levels radio button. 

d) Select description and click OK. 

The Choose Field dialog box closes, and the field appears in the left pane of the 

Create Data Movements dialog. 

e) Define the acctInfo.account.description data element: 

Data Source Type Web Service Client Output  

Service Output accountStatusMessage 

f) Click OK to close the Create Data Movements dialog box. 

AcctMainEWS Task 3S: Add an Operation End Node 

1. Drag an Operation End node onto the diagram and connect it to the Move to Output 

node. 

Define the node properties as follows: 

Property Value Comments 

Node ID Send Response   

2. The diagram is complete. Save the changes to the project. 

Your project diagram should resemble the diagram of the AcctMainEWS sample supplied with 

Ivory (in the \Samples folder). 

The next step is to build the Web service and generate the WSDL document. 

AcctMainEWS Task 4: Build Web Service and Generate WSDL Document 

After you have finished modeling the new Web service operation, you are ready to build it and 

generate the WSDL document. 

1. From the Ivory menu, select Tools> Build. 

o The Output window shows the Build Process Summary. Click the Output tab at the 

bottom of the screen to see the summary. 

After a successful build, the Output window displays the message Build Complete. If 

there are errors, you will see the message Build Complete With Errors. 

The summary provides a brief description of the Web service operation(s) in the 

project, including the location of the WSDL document(s). The build summary is not 

saved; if you need to view the build summary again, you can re-run the build process. 

o The WSDL document is generated. 

This WSDL document is saved using the project name and the WSDL file extension. Go 

to the Explorer window and click the Refresh  button to see the WSDL file. 

o An HTML file is generated. 

This HTML file describes the contents of the WSDL document, including the Web service 

name and description, Web service operation name and description, the input/output 

parameters, and a description of complex data types. 
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This HTML file is saved using the project name with an HTML file extension. Go to the 

Explorer window and click the Refresh  button to see the HTML file. If this filename 

does not appear in the Explorer window, click the Show All Files button. 

Next you will deploy the project. 

AcctMainEWS Task 5: Deploy the Project 

After you successfully build an Ivory project, you can deploy it to Ivory Server. You must 

deploy the project before you can test it. 

In order to deploy the project, you must have an FTP profile. You can use the FTP profile that 

you created for the AcctMain sample, or you can create a new FTP profile. 

1. From the Ivory menu bar, select File> Deploy Project to Server. 

You'll see a list of existing FTP profiles. 

2. Choose the FTP profile for the Ivory Server where you want to deploy the project, or 

create a new FTP profile. 

After you select an FTP profile, Ivory will select and upload the necessary files for the project 

being deployed, including the server instructions, maps, copybooks, and WSDL documents. 

When the process is complete, Ivory displays the messages Upload Complete and Deploy To 

Server Complete. 

If the upload is not successful, the FTP status messages are sent to the output window to 

help you resolve the problem. 

The files are uploaded to the URI location defined in the Start node of the project diagram, into 

a folder named WebServices and a subfolder using the project name. For example, you have a 

project that defines the Start node URI as http: //dev.gtsoftware.com: 8001/soap/apps/accts. 

Ivory deploys the project files to the /WebServices/soap/apps/accts folder. 

By default, Ivory Server treats any URI that begins with "soap" as a Web service rather than 

an HTML request. 

The final step is to test the new Web service operation. 

AcctMainEWS Task 6: Test the Web Service Operation 

After you deploy an Ivory project, you should test it. 

The Ivory FTP Server and the Ivory CICS TCPIPSERVICE must be active in order to run the 

Web service operation. 

1. From the Ivory menu bar, select Tools> Test to open the Test document window. 

2. Click Request to open the Request dialog box. 

The tree view lists the service inputs for the GetAccountNum request (defined in the Web 

Service Operation node). In this case, the service inputs are first name and last name. 

3. Click first. In the right-hand pane, you'll see information about the data element. Place 

the cursor in the Value field and type STEVE. 

4. Click last, and type SMITH in the Value field. 
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5. Click OK. 

The Request dialog box closes and you'll see the resulting XML code in the Request. 

6. Click Test to generate the Response. 

7. You can click Response to open the Response dialog box. 

You'll see that the service input (Steve, Smith) returns the following service outputs: 

name.title=MR, account.number=10001, account.status=A, and creditLimit=1000.00. 

To verify that the information you're getting is accurate, you can open an emulator window 

(Tools> Emulator), log on to the mainframe and verify the results. 

You have completed the Ivory tutorial—Congratulations!   
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Frequently Asked Questions 

How can I control access to the server? Answer 

How does Ivory use WSDL? Answer 

How do I build a Visual Studio ASP.NET application to access a Web service?  Answer 

How can I improve Ivory Server performance?   Answer 

During a 3270 session, can Ivory perform other processing (such as calling a LINK or IMS 

program or an external Web service) without terminating the 3270 session?  Answer 

How do I upgrade to Ivory from Process Extender (Novation)?  Answer 

What is the transaction flow of an HTTP request sent to Ivory Server?  Answer 

How can I define a different transaction code for each Web service?  Answer 

How can I add a user transaction ID based on a URL?  Answer 

How do I expand the diagram size?  Answer 

How do I move dockable windows?  Answer 

How do I connect to a node that isn't visible on the diagram?  Answer 

Why is some text in Ivory Studio truncated or aligned improperly?  Answer 

How can I verify that the Ivory internal Web services are functioning correctly?  Answer 
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How can I control access to the server? 
Suppose that you only want to allow company employees to access the server. One way to 

restrict access is to allow only IP addresses (or DNS names) used by your company. 

Create an {allow} section in the Ivory:/etc/giiipasp.ini file with entries that define the IP 

address ranges or DNS name forms used by your company. The {DAEMON} section must also 

include an entry specifying "Access_Rules=Allow". 

{Daemon} 

... 

Access_Rules=Allow 

... 

 

{allow} 

*.mycompany.com=allow anyone with a DNS name ending in ".mycompany.com" 

10.1.2.*=allow anyone with an IP address starting with "10.1.2." 

 

Suppose that you want to deny access to a specific user. One option is to deny the IP addresses 

(or DNS names) used by the user. 

Create a {Deny} section in the Ivory:/etc/giiipasp.ini file with entries that define the IP 

address ranges or DNS name forms used by that person. The {DAEMON} section must also 

include an entry specifying "Access_Rules=Deny". 

{Daemon} 

... 

Access_Rules=Deny 

... 

 

{deny} 

1.2.3.4=do not allow requests from IP address 1.2.3.4 

*.undesired.domain=reject requests from undesired domain 

 

Refer to /Ivory_doc/listener/server/gtssecr.htm#server_access_rules for more 

information. 
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What do I need to know about WSDL? 
You do not need to know WSDL in order to use Ivory, but a working knowledge of WSDL basics 

will be helpful. 

Web Services Description Language (WSDL) is an XML format for describing network services. A 

WSDL document defines services as collections of network endpoints (or ports). WSDL is an 

integral part of UDDI, an XML-based worldwide business registry. 

Ivory Web services support SOAP bindings only. Two styles of messaging for operations are 

supported: Document or RPC. Document-oriented messaging implies that messages contain 

XML documents that represent application data. RPC-oriented messaging implies that messages 

contain parameters and return values for remote procedure calls. 

Message parts are also affected by the encoding style, which can be either literal or encoded. 

The most common binding styles are document/literal and RPC/encoded, which are both 

supported by Ivory. For the document/literal binding style, Ivory uses a subset of the binding 

style named document/literal wrapped, which wraps the operation name as the top-level 

element in the message. The document/literal wrapped binding style is WS-I Basic Profile 1.0 

compliant. 

The Encoding Style property on the project Start Node specifies which style will be used for that 

project. 

Refer to <http://www.w3.org/TR/wsdl> for detailed information about WSDL. 

How do Ivory projects use WSDL? 

 Ivory Studio can use existing WSDL documents as a reference to define initial inputs and 

outputs for Ivory Web service or Callable service projects. Those initial inputs and outputs 

can be modified in Ivory Studio. 

 An Ivory project can call external Web services using Web Service Client Point Nodes. The 

node specifies the URI location of the WSDL document for the external Web service that 

will be called. Ivory reads this document to determine the SOAP inputs, outputs, and Web 

service operations that are available in the external Web service. The user chooses which 

operation(s) to call and uses movement nodes to move data to the inputs and from the 

outputs. 

 During the build of a Web Service project, Ivory Studio generates a WSDL document based 

on the Web service operations, SOAP inputs, and SOAP outputs defined in the project 

diagram. This document has the same name as the project file, with the .wsdl file 

extension. You can access the WSDL file from the Explorer window. Clients of the Ivory 

Web service use the details provided by the WSDL document to determine how to 

communicate with the Web service. 

 Ivory supports loosely typed Web services with extendable SOAP data by providing two 

special wildcard data types: Any Group and Any Attribute Group. When you define SOAP 

data with either of these types, Ivory generates a schema definition in the project WSDL 

stating that the data can be any element or any attribute (respectively). In effect, these 

data types indicate that, at runtime, the SOAP data can vary between requests. You must 

provide a type definition for an Any Group or Any Attribute Group in the SOAP data for the 

Web Service Operation Node and Web Service Client Point Node. 
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WSDL Input to Ivory 
Item Description 

Callable Service 

Operation Node  

The Reference WSDL properties enable you to use an existing WSDL 

document to populate the callable inputs and outputs. 

WSDL Location 

From the Set WSDL Location dialog, select the WSDL you want to use 

for this Callable service operation. The callable inputs and outputs will 

be initially populated from this WSDL, though you can modify those 

values. 

Caution: When you select a WSDL Location, it will overwrite any 

callable inputs or outputs you have previously defined for the node. 

Reference Web Service 

This field is automatically populated when you select a Reference WSDL 

Location. If there is more than one Web service defined in the 

Reference WSDL, select from the drop-down list. 

Reference Web Service Operation 

This field is automatically populated when you select a Reference WSDL 

Location. If there is more than one Web service operation defined in 

the Reference WSDL for the Web service, select from the drop-down 

list. 

Web Service 

Operation Node  

The Reference WSDL properties enable you to use an existing WSDL 

document to populate the SOAP inputs and outputs. 

WSDL Location 

From the Set WSDL Location dialog, select the WSDL you want to use 

for this Web service operation. The Web Service Name, Web Service 

Operation Name, SOAP inputs, and SOAP outputs will be initially 

populated from this WSDL, though you can modify those values. 

Caution: When you select a WSDL Location, it will overwrite any SOAP 

Inputs or SOAP Outputs you have previously defined for the node. 

Reference Web Service 

This field is automatically populated when you select a Reference WSDL 

Location. If there is more than one Web service defined in the 

Reference WSDL, select from the drop-down list. 

Reference Web Service Operation 

This field is automatically populated when you select a Reference WSDL 

Location. If there is more than one Web service operation defined in 

the Reference WSDL for the Web service, select from the drop-down 

list. 

If your project requires <any> support, remember to define the 

appropriate SOAP inputs, SOAP outputs, SOAP header inputs, and 

SOAP header outputs.  
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Item Description 

Web Service Client 

Point Node  

The WSDL Location property specifies the URI (Uniform Resource 

Identifier) of the WSDL document for the external Web service you 

want to call. 

Click to open the Set WSDL Location dialog. This dialog lists the 

WSDL sources supplied with Ivory Studio, as well as any other 

resources you've added through WSDL profiles. 

If your project requires <any> support, remember to define the 

appropriate Web Service Client SOAP inputs, SOAP outputs, SOAP 

header inputs, and SOAP header outputs.  

WSDL Output from Ivory 
Item Description 

Start Node  For a Web service project, the WSDL Location property specifies the 

URI (Uniform Resource Identifier) for the WSDL document that is 

generated during the project build. 
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How do I build a Visual Studio ASP.NET application to access 
a Web service? 
Here's an example that imports WSDL to create a simple ASP.NET application to access the 

supplied AcctMain sample. (You'll need to build and deploy the AcctMain sample project.) 

1. In Visual Studio, create a new ASP.NET Web application: from the main menu, select 

File> New Project. 

2. In the New Project dialog, select Visual C# as the project type, and ASP.NET Web 

Application as the template. Specify the location for the ASP.NET application, and then 

click OK. For this example, the location is: 

<http://localhost/AcctMain> 

3. Select View> Solution Explorer to display the Solution Explorer, if it is not already open. 

4. In the Solution Explorer, right-click the References node and select the Add Web 

Reference option. This will display the Add Web Reference dialog. 

5. In the URL text box of the Add Web Reference dialog, enter  

<http://localhost/soap/samples/acctmain?WSDL> 

6. Click Go to display an HTML page describing the WSDL. 

7. Click Add Reference to add the WSDL reference to project. 

8. Go to the Solution Explorer tab and select the WebForm node called WebForm1.aspx, 

which is created by default. Right-click WebForm1.aspx and select Open. This will open a 

design view MDI tab with a blank form. 

9. Select View> Toolbox to open the ToolBox window. Drag and drop 3 labels, 3 text boxes 

and a button from the toolbox onto the design view and position them. 

10. Select View> Properties to open the Properties window, if it is not already open. 

11. Define the text property for the labels: First Name, Last Name, and Account Number. 

12. Define the text box ID properties: TxtFirstName, TxtLastName, and 

TxtAccountNumber. 

13. Define the text property for the button: Submit. 

14. Double-click the button to view the source code for the form with a template for the button 

click event handler. In the given solution, it is: 

private void Button1_Click(object sender, System.EventArgs e) 

{} 

15. Insert code to call the Web service operation. For example, here is code to call the 

supplied AcctMain sample: 

//get firstName value from Text Field 

string firstName = this.TxtFirstName.Text; 

//get lastName value from TextField 

string lastName = this.TxtLastName.Text; 

//Create an instance of the web service class. 

AcctMain.com.yourdomain.yourhost.AcctMain acctMain = new 

AcctMain.com.yourdomain.yourhost.AcctMain(); 

//Call the operation GetAccountNum. It returns a complex type  

//"AcctInfoType". .Net creates a class for each complex type. 
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//The Account Number is a member of the class. Assign the  

//accountNumber value to display in the AccountNumber  

//text box. 

AcctMain.com.yourdomain.yourhost.AcctInfoType infoType = 

acctMain.GetAccountNum(lastName, firstName); 

//Get AcctInfoType instance and obtain value of member accountNumber.  

this.TxtAccountNumber.Text = infoType.accountNumber; 

16. Run the application using Debug> Start. This will display the Web form on an HTML page 

with the defined text fields for input. Enter values into the name text fields, and click 

Submit to access account number values from the Web service. 
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How can I improve Server performance? 
1. Place the IV$FILE in an LSR pool. (Data CI size is 26K, key CI size is 1536) 

Benefit: This results in reduced physical I/O on the IV$FILE and a reduction of CPU 

consumption at a cost of increased storage usage. 

2. Define the IV$FILE as a CICS maintained table (see below). The IV$FILE must already be 

defined in an LSR pool; see above. 

Benefit: This will improve the I/O processing of the IV$FILE and reduce the response time 

when running in an MRO situation more than using only an LSR pool. 

 

3. Verify that the server DNS settings have been configured properly. Using the Ivory Server 

Administration Manager, go to Server Controls> Ivory Listener> DNS> DNS Settings 

and verify that the DNS Name Suffx and DNS IP Address settings have been updated with 

the correct values for your installation. 

To measure performance, monitor all IVCW transactions and all defined alias transactions. 
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During a 3270 session, can other processing be performed 
without terminating the 3270 session? 
During a 3270 session, can Ivory perform other processing (such as calling a LINK or IMS 

program or an external Web service) without terminating the 3270 session? 

Yes, Ivory provides ways to logically suspend an active 3270 session, do other processing, and 

then resume the 3270 session. You can have an implicit suspend and an explicit suspend. 

Implicit Suspend 

There may be 3270 Point Nodes that are indirect descendants (not immediate children) of the 

3270 Action Node, but they are part of the same 3270 session (they occur before another 3270 

Process Node). If the diagram is arranged in this way and if Ivory Server doesn't find a direct 

child 3270 Point Node that matches the next runtime screen, then Ivory Server will logically 

suspend the 3270 session and execute the path of the first non-3270 Point Node child. When 

Ivory Server encounters the next 3270 Point node in this path, the 3270 session is resumed, 

provided that this 3270 Point Node does match the next runtime screen; otherwise it is a SOAP 

fault. 

Explicit Suspend 

The service may need to use data fields from the last active 3270 screen as inputs to a LINK 

program or external Web service call (Web Service Client). This is not possible using the implicit 

suspend method because the 3270 Point Node for the active screen does not occur in the 

diagram until after the nodes for the other processing. 

In this case, you need to perform an explicit suspend, as follows: 

 Establish an active 3270 session with a 3270 Process Node followed by any number of 

3270 Point Nodes and 3270 Action Nodes. 

 At the point where you want to do other processing, place a 3270 Action Node followed by 

the 3270 Point Node representing the resulting screen. 

 Then insert a second 3270 Action Node with AID Key set to “Suspend”. This explicitly tells 

Ivory Server to logically suspend the 3270 session. 

 Following this 3270 Action Node, insert nodes to perform the other processing (LINK, IMS, 

or Web Service Client). 

 When you want to resume the 3270 session, insert another 3270 Point Node with the 

same map as the 3270 Point Node before the “Suspend” 3270 Action Node. 

Using this method, nodes doing the other processing can use fields from the 3270 Point Node 

preceding the “Suspend” 3270 Action Node as inputs. 
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How Do I Upgrade from Process Extender (Novation)? 
Existing Process Extender (formerly Novation) customers should follow the steps below to 

upgrade to Ivory. 

1. Backup Process Extender (Novation) files. 

Use IDCAMS to backup your current GI$FILE and any other Process Extender (Novation) 

files. 

2. Download installation files. 

Your software provider will direct you to a download location on the GT Software FTP site. 

Download the specified .zip file and unzip it to your hard drive. 

3. Prepare XMIT jobs. 

After you unzip the file, you will see the INSTLIB directory. There you'll find the following 

jobs: CDFIX01.TXT, CDTSK01.TXT, CDTSK02.TXT and CDTSK03.TXT. 

Alter these jobs and use them to pre-allocate, upload, and RECEIVE the XMIT files on your 

mainframe. 

4. Modify the CSD. 

Copy member SAMPLIB(GIICSD) to another name, such as GIIGTI. Then modify GIICTI by 

changing all of the transaction codes from IV* to GI*, using a command such as the 

following: 

C ‘TRANSACTION(IV’ ‘TRANSACTION(GI’ ALL 

Change the CSD group name from Ivory30 to IvoryGI. 

Use the INSTLIB(TASK04) job to add the new CSD to your region. You do not need to run 

all of the CSDs; just install the IvoryGI member that has the Ivory programs and GI* 

transactions defined. 

5. Add Ivory LOADLIBS to CICS startup JCL. 

Place the Ivory LOADLIBS in your CICS startup JCL. Place both libraries in front of your 

existing Process Extender (Novation) libraries. 

6. PLT startup/shutdown. 

If you are using the PLT to startup and shutdown Process Extender (Novation), you will 

continue to do so when using the Ivory code base. Leave GTIPLTSI and GTIPLDSD in your 

PLT table. 

7. Restart the CICS region. 

After you restart the CICS region, verify that the proper groups have been loaded. All GI* 

transactions should now be running Ivory programs. For example: GIAS should be running 

program GIIIPASP. 

8. Apply Ivory passwords. 

Use the GII transaction to apply passwords to the file. Passwords are provided by your 

software supplier. 

9. Backup existing INI files. 

Using the GIC transaction, switch to directory \ETC. 

Check whether you have a directory under \ETC named SAVE. If not, create it. 
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From the \ETC directory, type the command COPY GTI*.INI GT:\ETC\SAVE 

This will backup all of the INI files to the \SAVE directory. 

10. Copy the INI files. 

Using the GIC transaction, copy the existing GTI*.INI files to GII*.INI files. You must copy 

these files one at a time. 

Use DIR GTI*.INI to get a list of the INI files. Then copy each one to its new name; for 

example, COPY GTIIPASP.INI GIIIPASP.INI. 

11. If using CGIs, re-link your programs. 

If you use CGIs, re-link your programs using the HFSAPI from the Ivory LOADLIB. 

12. Recycle region or shutdown GIAS and GIRV. 

Recycle the CICS region (recommended), or use SHUTDOWN commands to stop the server 

and FTP. The SHUTDOWN commands are: GIAS SHUTDOWN and GIRV SHUTDOWN. 

13. Test. 

Begin testing. You will be using the GI$FILE and the GI* transactions just as before. 
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What is the transaction flow of an HTTP request? 
1. A connection from an external agent (application) arrives at the host system. 

2. Based upon the TCP/IP service definition, this triggers transaction IVCW; the port for this 

service is 8080. 

I TCPIPS(Ivory*) 

 STATUS: RESULTS - OVERTYPE TO MODIFY 

  Tcpips(IvoryTCP) Bac( 00010 ) Con(0000) Por(08080) Http Nos 

        Ope Tra(IVCW) Urm( GIIANALZ ) Ipa(0.0.0.0    ) Tim 

3. The Transaction IVCW is defined as follows: 

I TRANS(IVCW) 

STATUS: RESULTS - OVERTYPE TO MODIFY 

 Tra(IVCW) Pri( 001 ) Pro(DFHWBXN ) Tcl(DFHTCL00 ) Ena Sta 

       Prf(DFHCICST) Uda Any Iso        Bac Wai 

4. The application makes a SOAP request using URL with SOAP request packets. 

For example: <http://your_Ivoryserver.com:port/soap/test/test>. 

5. The IVCW task associated with that socket session will read the inbound request. 

6. DFHWBXN then links to GIIANALZ, which is the program specified in the URM parameter of 

the TCPIP Service definition. 

7. GIIANALZ is passed a COMMAREA which it will populate with information which CICS Web 

Services (DFHWBXN) will use to start an alias transaction (to process the request). This 

information includes the alias transaction ID to use, and programs to invoke to process the 

request. 

8. GIIANALZ examines the URL and sets an alias transaction based on the URL method 

defined by the Ivory Administrator. For example, by default, any URL containing "/soap/" 

will set the alias transaction IVWA which is defined as follows: 

I TRANS(IVWA) 

STATUS: RESULTS - OVERTYPE TO MODIFY 

 Tra(IVWA) Pri( 001 ) Pro(DFHWBA ) Tcl( DFHTCL00 ) Ena Sta 

       Prf(DFHCICST) Uda Any Iso        Bac Wai 

If you decide to create your own alias transactions, you should clone (copy) the IVWA 

transaction and make your own transaction. You should not reuse existing transaction IDs. 

9. The alias transaction (IVWA or your defined transaction) processes the application logic. 

a) DFHWBXN performs further processing of the request based on the information 

output in the COMMAREA passed to GIIANALZ. This includes: 

 performing optional code page conversion 

 performing optional transformation (unescapDevaSearching) of HTML entity tags 

 starting the alias transaction (optionally with the user ID specified by GIIANALZ) 

b) The alias transaction (IVWA) has been started. DFHWBA links to the program 

specified in the converter field (this is GIISOAP in the "/soap/" example) for the 

"decode" stage. 

c) In the decode stage, GIISOAP parses the XML, loads the appropriate Ivory project 

and executes the commands contained therein. GIISOAP then returns to DFHWBA. 
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d) DFHWBA links to the service program from the Server method definition. (For 

Ivory SOAP server processing, this field is empty and no link occurs.) 

e) DFHWBA then links to GIISOAP for decode processing. GIISOAP performs 

processing necessary to complete the response and returns to DFHWBA. 

f) CICS Web Services returns the Web Service response to the user agent 

(application). 

g) Further requests from the user agent (application) go into step 3 above. 

The IVCW task remains active as long as the socket session with the client is 

active) This duration can be tuned by configuration of the SOCKETCLOSE parameter 

of the TCPIPService definition. 

h) When the socket session closes, the IVCW task associated with the socket session 

terminates. 
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How can I define a different transaction code for each Web 
service? 
To add a user transaction ID based on a URL, you must modify the Ivorycwi.ini file. You can 

use the Ivory Administration Manager tool to modify the file. 

Modify the IvoryCWI.INI File Using the Ivory Administration Manager Tool 

1. Log on to the Ivory Administration Manager in a browser window using the URL below. 

<http://your.Ivoryserver.com:nnnn> 

2. Select Server Controls. 

3. From the Server Controls panel, select Methods. 

 

Before you continue, you need to understand how Ivory processes a URL. 

A typical URL has the format <http://www.yourcompany.com:port/soap/xyz/abc>. The URL 

identifies a directory structure that describes where the information is located. 
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GT uses portions of the URL as a "method” to describe its properties. For example, in our 

example, /soap/, /xyz/, or /abc can be a method. 

The URL that the client application passes to Ivory server is parsed through the {Methods} 

section of the IvoryCWI.ini file. 

The Server Methods section tells Ivory Server how to process the request: commonly a SOAP 

request, script request, or default HTML page retrieval. If there is not a match in this section, 

by default Ivory will treat the request as an HTML page retrieval. 

For example, let's use the URL 

<HTTP://www.yourcompany.com:port/soap/samples/acctmain>. 

To examine the details of the SOAP method, select the Expand radio button and then click 

Process. You'll see that the method is processing the IVWA transaction using the GIISOAP 

converter module. The userID entry of * indicates that you want to validate the RACF userid. 

4. On a blank line, type in the URL pattern in the left column, and then identify the user-

defined method in the center column. Select the Add option, and then click Process to 

add the entry. 

Note: The user-defined method name cannot contain blanks or special characters. 

5. Select the Expand option for the new entry, and then click Process. This displays the 

parameters for the user-defined method. 

6. Specify the following parameters: 

o Description 

o Alias_TransID (Must be defined to CICS using CEDA, with parameters identical to the 

IVWA transaction) 

o Converter (GIISOAP) 

7. Click Process. 

If you want security for the new method, continue with step 8; otherwise, skip to step 13. 

8. Select the Security: Basic Authentication option from the Server Controls menu. 

9. On a blank line, type the method (such as /signon/*), and then add a description of the 

entry in the field to the right. 
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10. Select the Add radio button and then click Process. 

11. Click the Utilities tab at the top of the screen. 

12. Select Control Queue and then click Process. This will clear the temporary storage 

queues and activate the new settings. 

13. Click Save and Exit to save your changes and exit the Ivory Server Administration 

Manager. 

Caution: If you do not click Save and Exit, your changes will be lost! 

For more information, refer to Using the Analyzer Initialization File and URL Processing of 

IvoryCWI.INI Methods. 
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How can I add a user transaction ID based on a URL? 
1. Start the Ivory Administration Manager: in a browser window, type the URL 

<http://local_host:port/Ivory.lua>. 

2. Log on to Ivory Server administration. 

3. Select Server Methods. 

4. On the last line, type the URL portion in the first column, and then type the Methods 

section name in the next column. (Do not use blanks or special characters.) Select the 

Add option, and then click Process. 

For example, you might enter the URL */mytest/* and name the method mytestsrv. 

5. Select the Expand option for the newly added URL, and click Process. The selected entry 

is expanded to display method details. 

6. Define the method parameters: 

o Specify the Alias_Tranid; this transaction must be defined to CICS using CEDA and 

clone the IVWA transaction); for example, TST1. 

o Enter the Description. 

o Specify the Converter name (GIISOAP). 

7. Click Process. 

This creates an entry in the Ivory cwi.ini file for the new server method mytestsrv, which is 

associated with the transaction TST1. 
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How do I expand the diagram size? 
The diagram size increases as components are added. You do not need to manually specify the 

diagram size. 

For example, if you want to begin adding components to the right of the existing diagram 

border, add the next component and drag it to the right edge. When you release the mouse 

button, the new node will be positioned to the right of the former edge. 

You can add components in any direction: up, down, left or right. 
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How do I reposition a dockable window (such as Toolbox, 
Explorer, Properties, Output)? 
To move an Ivory dockable window, simply click and drag the title bar of the dockable window 

you want to move. You must place the mouse cursor on the line that forms the border you want 

to dock against. When you release the mouse button, the window will dock in the new position. 

If the window remains in its previous position, you need to try again! Be sure to drag the 

mouse pointer over the border where you want to dock. When you've reached the right 

position, you will see the outline of the new location where the window will be docked, and 

the mouse pointer will change from the Ø symbol. 

For example, if you want to move the Toolbox from the left side to the right side, click and drag 

the "Toolbox" title bar. Drag the mouse to the far right side of the screen. When the mouse 

pointer is over the line at the right edge of the Ivory Studio window, you will see the outline of 

the new window location. 

Below are samples of the right way and the wrong way to reposition a dockable window. Notice 

the location of the mouse pointer and the outline of the dockable window. Release the mouse 

button and it will dock to this location. 

Right way: 

 

 

Wrong way: 
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To group multiple dockable windows so that they are tabbed, drag the title bar of one dockable 

window on top of the title bar of another dockable window and release the mouse button. 

To remove a dockable window from a tabbed group, click and drag it by the tab rather than the 

title bar. 

You can select Window> Default Window Layout to easily return to the default layout. 
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How do I connect to a node that isn't visible on the diagram? 
One quick solution is to change the size of the entire diagram so that you can see both nodes at 

once. To do this, go to View> Zoom, and select a different zoom value. For example, if you're 

working at 100% resolution, changing to 50% will double the viewable area of the diagram. 

Then connect the nodes as usual. You can return to the original resolution at any time. 

This method is quick, but some users may have trouble reading the smaller component IDs 

or maneuvering the cursor to the smaller connection points. 

Another way is to scroll the diagram view to locate the second node. 

1. Click on the connection point of one node. (The arrow cursor changes to a hand.) Do not 

release the mouse button. 

2. Move the cursor near the edge of the diagram area and the diagram will start to scroll in 

that direction. (The cursor must be near the edge to start the auto scrolling process.) You 

can scroll up, down, left, or right. Remember that you must hold down the mouse button 

while you scroll. 

3. When you've scrolled to the location of the second node, position the cursor on the target 

connection point. Release the mouse button to complete the connection. 

If you drag the hand outside the diagram screen area then scrolling with stop. When you 

reach the current boundary of the diagram area, scrolling will stop. 

A third option is to create (or move) the second node near the first node and make the 

connection, and then reposition the second node. You'll need to scroll the diagram as explained 

above. 
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Why is some text in Studio truncated or aligned improperly? 
Ivory Studio supports both Normal size (96 DPI) or Large size (120 DPI) display; it does not 

currently support the Custom DPI setting in Windows. Select either Normal or Large size, and 

Ivory Studio should display correctly. 

From the Windows Start menu, select Settings> Control Panel> Display> Appearance, and 

set DPI Setting to Normal or Large. 
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How can I verify that the internal Web services are functioning 
correctly? 
All Ivory internal Web services include a getVersionInfo operation. 

The following data is returned when you call the getVersionInfo Web service operation.  

Item Description 

serviceName Returns the name of the Web service 

serviceCreationDate Returns the date the service was created  

serviceReleaseNumber   Returns the service release number 

currentDateTime Returns the current date and time 

These SOAP outputs are child nodes of the getVersionOut complex type. You can retrieve this 

information when calling the getVersionInfo Web service operation with no SOAP inputs. 
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Getting Technical Support 

Product Documentation 

The online help system is the first place to look when you need information about the product. 

GT Software Website 

From the Support section of the GT website you can: 

 search the Support Portal for knowledge base articles and software downloads 

 submit an Enhancement Request 

Technical Support Staff 

If you cannot resolve the problem using the product documentation or online knowledge base, 

the GT Technical Support staff is available for telephone consultation Monday through Friday 

between the hours of 8:30 AM and 5:15 PM Eastern time. After business hours, you can leave a 

message. Your call will be returned the next business day. Before you call: 

 Try to re-create the problem 

 Have the following information available: 

 Product release number 

 Operating system type and version 

 The text of the system message (if any) 

 Complete description of the problem 

Important: In order to resolve a problem it is important to tell the Technical Support 

representative exactly what was being done when the problem occurred—details are important. 

It may be helpful to make notes about what happened before you call. 

Contacting GT Software 

Visit the GT Software website at http://www.gtsoftware.com 

Send Internet e-mail to sales@gtsoftware.com or support@gtsoftware.com 

To send a facsimile (fax), dial 404-253-1314. 

Call GT Software at 404-253-1300 or toll free: 800-756-43GT (4348). Customers outside 

of the U.S. can contact their authorized GT agent for technical support. If the agent is 

unavailable, contact GT Software directly. 

Documentation version: 291118 

http://help.gtsoftware.com/
http://www.gtsoftware.com/
mailto:sales@gtsoftware.com
mailto:support@gtsoftware.com




 

Getting Started Ivory Service Architect 101 

Index 

* 

*AcctMain data collection: Data Movements 

(Move to LINK node) 24 

*AcctMain data collection: Service Inputs 

(Web Service Operation Node) 19 

*AcctMain data collection: Service Output 

Data Movements (Move to Output 

node) 27 

*AcctMain data collection: Service Outputs 

(Web Service Operation node) 21 

*AcctMain3270 data collection: Data 

Movements (Move to 3270 node) 43 

*AcctMain3270 data collection: Service 

Inputs (Web Service Operation node) 

40 

*AcctMain3270 data collection: Service 

Output Data Movements (Move to 

Output node-Active) 48 

*AcctMain3270 data collection: Service 

Output Data Movements (Move to 

Output node-Closed) 51 

*AcctMain3270 data collection: Service 

Output Data Movements (Move to 

Output node-Inactive) 49 

*AcctMain3270 data collection: Service 

Output Data Movements (Move to 

Output node-Save Account Number) 45 

*AcctMain3270 data collection: Service 

Output Data Movements (Move to 

Output node-Unknown) 52 

*AcctMain3270 data collection: Service 

Outputs (Web Service Operation node) 

41 

*AcctMainEWS data collection: Data 

Movements (Move to 3270 node) 63 

*AcctMainEWS data collection: Data 

Movements (Move to Web Service 

Client node) 68 

*AcctMainEWS data collection: Service 

Inputs (Web Service Operation node) 

61 

*AcctMainEWS data collection: Service 

Output Data Movements (Move to 

Output node-Move) 69 

*AcctMainEWS data collection: Service 

Output Data Movements (Move to 

Output node-Save Account Number) 65 

*AcctMainEWS data collection: Service 

Outputs (Web Service Operation node) 

61 

A 

AcctMain Task 1: Create the Project File 14 

AcctMain Task 2: Import the BMS Mapsets 

and COBOL Copybooks 14 

AcctMain Task 3: Model the Web Service 

Operation 15 

AcctMain Task 3A: Add a Start Node 16 

AcctMain Task 3B: Add a Web Service 

Operation node 18 

AcctMain Task 3C: Add a Link Point node 22 

AcctMain Task 3D: Add a Move to Link node 

23 

AcctMain Task 3E: Add an Execute Link 

Node 26 

AcctMain Task 3F: Add a Move to Output 

Node 26 

AcctMain Task 3G: Add an Operation End 

Node 29 

AcctMain Task 4: Build Web Service and 

Generate WSDL Document 29 

AcctMain Task 5: Deploy the Project 30 

AcctMain Task 6: Test the Web Service 

Operation 31 

AcctMain3270 Task 1: Create the Project 

File 36 

AcctMain3270 Task 2: Import the BMS 

Mapsets and COBOL Copybooks 36 

AcctMain3270 Task 3: Model the Web 

Service Operation 37 

AcctMain3270 Task 3A: Add a Start Node 38 

AcctMain3270 Task 3B: Add a Web Service 

Operation Node 39 

AcctMain3270 Task 3C: Add a 3270 Process 

Node 42 

AcctMain3270 Task 3D: Add a 3270 Point 

Node 42 

AcctMain3270 Task 3E: Add a Move to 3270 

Node 42 



Index 

102 Getting Started Ivory Service Architect 

AcctMain3270 Task 3F: Add a 3270 Action 

Node 44 

AcctMain3270 Task 3G: Add a 3270 Point 

Node 44 

AcctMain3270 Task 3H: Add a Move to 

Output Node 44 

AcctMain3270 Task 3I: Add a Decision Node 

47 

AcctMain3270 Task 3J: Add a Move to 

Output Node 48 

AcctMain3270 Task 3K: Add a Decision 

Node 49 

AcctMain3270 Task 3L: Add a Move to 

Output Node 49 

AcctMain3270 Task 3M: Add a Decision 

Node 50 

AcctMain3270 Task 3N: Add a Move to 

Output Node 51 

AcctMain3270 Task 3O: Add a Move to 

Output Node 51 

AcctMain3270 Task 3P: Add a Connector 

Node 52 

AcctMain3270 Task 3Q: Add a 3270 Action 

Node 52 

AcctMain3270 Task 3R: Add an Operation 

End Node 53 

AcctMain3270 Task 4: Build Web Service 

and Generate WSDL Document 53 

AcctMain3270 Task 5: Deploy the Project 54 

AcctMain3270 Task 6: Test the Web Service 

Operation 54 

AcctMainEWS Task 1: Create the Project File 

58 

AcctMainEWS Task 2: Import the BMS 

Mapsets and COBOL Copybooks 59 

AcctMainEWS Task 3: Model the Web 

Service Operation 59 

AcctMainEWS Task 3A: Add a Start Node 59 

AcctMainEWS Task 3B: Add a Web Service 

Operation Node 60 

AcctMainEWS Task 3C: Add a 3270 Process 

Node 62 

AcctMainEWS Task 3D: Add a 3270 Point 

Node 62 

AcctMainEWS Task 3E: Add a Move to 3270 

Node 62 

AcctMainEWS Task 3F: Add a 3270 Action 

Node 63 

AcctMainEWS Task 3G: Add a 3270 Point 

Node 63 

AcctMainEWS Task 3H: Add a 3270 Action 

Node 64 

AcctMainEWS Task 3I: Add an Operation 

End Node 64 

AcctMainEWS Task 3J: Add a 3270 Point 

Node 64 

AcctMainEWS Task 3K: Add a Move to 

Output Node 65 

AcctMainEWS Task 3L: Add a 3270 Action 

Node 66 

AcctMainEWS Task 3M: Add a Decision Node 

67 

AcctMainEWS Task 3N: Add an Operation 

End Node 67 

AcctMainEWS Task 3O: Add a Web Service 

Client Point Node 68 

AcctMainEWS Task 3P: Add a Move to Web 

Service Client Node 68 

AcctMainEWS Task 3Q: Add an Execute Web 

Service Client Node 69 

AcctMainEWS Task 3R: Add a Move to 

Output Node 69 

AcctMainEWS Task 3S: Add an Operation 

End Node 70 

AcctMainEWS Task 4: Build Web Service 

and Generate WSDL Document 70 

AcctMainEWS Task 5: Deploy the Project 71 

AcctMainEWS Task 6: Test the Web Service 

Operation 71 

D 

Diagram Window 7 

During a 3270 session, can other processing 

be performed without terminating the 

3270 session? 83 

E 

Explorer Window 8 

H 

How can I add a user transaction ID based 

on a URL? 91 

How can I control access to the server? 76 

How can I define a different transaction 

code for each Web service? 88 

How can I improve Server performance? 82 

How can I verify that the internal Web 

services are functioning correctly? 97 

How do I build a Visual Studio ASP.NET 

application to access a Web service? 80 

How do I connect to a node that isn't visible 

on the diagram? 95 



Index 

Getting Started Ivory Service Architect 103 

How do I expand the diagram size? 92 

How do I reposition a dockable window 

(such as Toolbox, Explorer, Properties, 

Output)? 93 

How Do I Upgrade from Process Extender 

(Novation)? 84 

K 

Keyboard Navigation 11 

N 

Navigating Studio 6 

O 

Output Window 11 

P 

Properties Window 10 

S 

Sample Project: AcctMain 12 

Sample Project: AcctMain3270 34 

Sample Project: AcctMainEWS 57 

T 

Toolbox Window 8 

W 

What do I need to know about WSDL? 77 

What is Ivory Server? 3 

What is Ivory Studio? 2 

What is the transaction flow of an HTTP 

request? 86 

Why is some text in Studio truncated or 

aligned improperly? 96 

 


	Introduction to Ivory Service Architect
	What is Ivory Studio?
	What is Ivory Server?

	Ivory Studio Quick Start Guide
	Navigating Studio
	Diagram Window
	Explorer Window
	Toolbox Window
	Properties Window
	Output Window
	Keyboard Navigation

	Sample Project: AcctMain
	AcctMain Task 1: Create the Project File
	AcctMain Task 2: Import the BMS Mapsets and COBOL Copybooks
	AcctMain Task 3: Model the Web Service Operation
	AcctMain Task 3A: Add a Start Node
	AcctMain Task 3B: Add a Web Service Operation node
	*AcctMain data collection: Service Inputs (Web Service Operation Node)
	*AcctMain data collection: Service Outputs (Web Service Operation node)

	AcctMain Task 3C: Add a Link Point node
	AcctMain Task 3D: Add a Move to Link node
	*AcctMain data collection: Data Movements (Move to LINK node)

	AcctMain Task 3E: Add an Execute Link Node
	AcctMain Task 3F: Add a Move to Output Node
	*AcctMain data collection: Service Output Data Movements (Move to Output node)

	AcctMain Task 3G: Add an Operation End Node

	AcctMain Task 4: Build Web Service and Generate WSDL Document
	AcctMain Task 5: Deploy the Project
	AcctMain Task 6: Test the Web Service Operation

	Sample Project: AcctMain3270
	AcctMain3270 Task 1: Create the Project File
	AcctMain3270 Task 2: Import the BMS Mapsets and COBOL Copybooks
	AcctMain3270 Task 3: Model the Web Service Operation
	AcctMain3270 Task 3A: Add a Start Node
	AcctMain3270 Task 3B: Add a Web Service Operation Node
	*AcctMain3270 data collection: Service Inputs (Web Service Operation node)
	*AcctMain3270 data collection: Service Outputs (Web Service Operation node)

	AcctMain3270 Task 3C: Add a 3270 Process Node
	AcctMain3270 Task 3D: Add a 3270 Point Node
	AcctMain3270 Task 3E: Add a Move to 3270 Node
	*AcctMain3270 data collection: Data Movements (Move to 3270 node)

	AcctMain3270 Task 3F: Add a 3270 Action Node
	AcctMain3270 Task 3G: Add a 3270 Point Node
	AcctMain3270 Task 3H: Add a Move to Output Node
	*AcctMain3270 data collection: Service Output Data Movements (Move to Output node-Save Account Number)

	AcctMain3270 Task 3I: Add a Decision Node
	AcctMain3270 Task 3J: Add a Move to Output Node
	*AcctMain3270 data collection: Service Output Data Movements (Move to Output node-Active)

	AcctMain3270 Task 3K: Add a Decision Node
	AcctMain3270 Task 3L: Add a Move to Output Node
	*AcctMain3270 data collection: Service Output Data Movements (Move to Output node-Inactive)

	AcctMain3270 Task 3M: Add a Decision Node
	AcctMain3270 Task 3N: Add a Move to Output Node
	*AcctMain3270 data collection: Service Output Data Movements (Move to Output node-Closed)

	AcctMain3270 Task 3O: Add a Move to Output Node
	*AcctMain3270 data collection: Service Output Data Movements (Move to Output node-Unknown)

	AcctMain3270 Task 3P: Add a Connector Node
	AcctMain3270 Task 3Q: Add a 3270 Action Node
	AcctMain3270 Task 3R: Add an Operation End Node

	AcctMain3270 Task 4: Build Web Service and Generate WSDL Document
	AcctMain3270 Task 5: Deploy the Project
	AcctMain3270 Task 6: Test the Web Service Operation

	Sample Project: AcctMainEWS
	AcctMainEWS Task 1: Create the Project File
	AcctMainEWS Task 2: Import the BMS Mapsets and COBOL Copybooks
	AcctMainEWS Task 3: Model the Web Service Operation
	AcctMainEWS Task 3A: Add a Start Node
	AcctMainEWS Task 3B: Add a Web Service Operation Node
	*AcctMainEWS data collection: Service Inputs (Web Service Operation node)
	*AcctMainEWS data collection: Service Outputs (Web Service Operation node)

	AcctMainEWS Task 3C: Add a 3270 Process Node
	AcctMainEWS Task 3D: Add a 3270 Point Node
	AcctMainEWS Task 3E: Add a Move to 3270 Node
	*AcctMainEWS data collection: Data Movements (Move to 3270 node)

	AcctMainEWS Task 3F: Add a 3270 Action Node
	AcctMainEWS Task 3G: Add a 3270 Point Node
	AcctMainEWS Task 3H: Add a 3270 Action Node
	AcctMainEWS Task 3I: Add an Operation End Node
	AcctMainEWS Task 3J: Add a 3270 Point Node
	AcctMainEWS Task 3K: Add a Move to Output Node
	*AcctMainEWS data collection: Service Output Data Movements (Move to Output node-Save Account Number)

	AcctMainEWS Task 3L: Add a 3270 Action Node
	AcctMainEWS Task 3M: Add a Decision Node
	AcctMainEWS Task 3N: Add an Operation End Node
	AcctMainEWS Task 3O: Add a Web Service Client Point Node
	AcctMainEWS Task 3P: Add a Move to Web Service Client Node
	*AcctMainEWS data collection: Data Movements (Move to Web Service Client node)

	AcctMainEWS Task 3Q: Add an Execute Web Service Client Node
	AcctMainEWS Task 3R: Add a Move to Output Node
	*AcctMainEWS data collection: Service Output Data Movements (Move to Output node-Move)

	AcctMainEWS Task 3S: Add an Operation End Node

	AcctMainEWS Task 4: Build Web Service and Generate WSDL Document
	AcctMainEWS Task 5: Deploy the Project
	AcctMainEWS Task 6: Test the Web Service Operation


	Frequently Asked Questions
	How can I control access to the server?
	What do I need to know about WSDL?
	How do I build a Visual Studio ASP.NET application to access a Web service?
	How can I improve Server performance?
	During a 3270 session, can other processing be performed without terminating the 3270 session?
	How Do I Upgrade from Process Extender (Novation)?
	What is the transaction flow of an HTTP request?
	How can I define a different transaction code for each Web service?
	How can I add a user transaction ID based on a URL?
	How do I expand the diagram size?
	How do I reposition a dockable window (such as Toolbox, Explorer, Properties, Output)?
	How do I connect to a node that isn't visible on the diagram?
	Why is some text in Studio truncated or aligned improperly?
	How can I verify that the internal Web services are functioning correctly?

	Getting Technical Support
	Index

